Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts replaced with question marks in boxes

  • 16 replies
  • 1 has this problem
  • Last reply by cor-el

more options

This problem is not new. Every time I've gotten fed up with Chrome and have fled to Firefox I've had this problem... I'm talking years! Screenshots are attached.

If I just open Gmail, fonts display correctly in my inbox. If I click on an email to open a website, or type something into a Google search, I get what's attached. I have none of these problems using Chrome, Safari, or doing a Yahoo search.

I don't know if it's a font conflict? I've cleared the cache and cookies and restarted. I've opened Firefox in Safe Mode... the issue persists. Our Mac Book Pro laptop using Firefox as the browser also does not have any issues.

I hope someone has some experience with this so I can FINALLY fix this. Thanks to anyone who can help!

Attached screenshots

All Replies (16)

more options

The question marks in the boxes means the computer does not know how to display the character.

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash

more options

Hi vickifeldman, did you post a question before or is this the first time?

Several years ago, when Firefox 56 cranked up security on MacOS, many users discovered that third party font managers (that is, other than Apple's built-in font manager) sometimes stored font files in folders that Firefox considered to be off-limits with the stricter new security sandbox, so their Firefox wouldn't load most fonts. Over the years, more of these locations have been accounted for so this should be much less of an issue. That said, if you want to try relaxing the security sandbox level, you could look at this older thread for the steps: when I open Firefox and search, the results come up with a lot of boxes with "A's" in them.

More recently, Mac users have had odd results using default fonts that point to Adobe Type1 fonts. If you change those to TrueType fonts supplied with your system, that can help. Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

more options

Like, posted above, this happens when Firefox can't access the requested font and instead switch to a last resort font that shows all characters as a '?'.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text.
You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

Thank you for your replies. I was anxious to try everything, sure that something would finally solve this issue! Sadly, no.

Latin and 'allow pages to choose their own fonts' were already selected. I did change the fonts to New Times Roman, Arial, and Courier New.

The developer area is a little trickier since I'm not familiar with it. I opened the panel and found the Fonts tab, but have no idea whether anything should be changed. (screenshot attached) I could not find a 'Rules' tab.

Unfortunately, I can't see what's on the Browser Spy site for the same reason we're all here!

I'm happy to try any other suggestions.

Modified by vickifeldman

more options

Hi vickifeldman, the Latin vs. Other Writing Systems selector isn't a setting you control, it lets you set fonts for both of those common character sets declared by pages.

At the very bottom of your screenshot is the weird font, " .SF NS " which I guess is an Apple System Font that is being substituted for some other font. Can you inspect a more specific problem element (such as a heading or paragraph) and see whether it indicates the assigned font it is substituting?

more options

Judging from the fonts shown in the first screenshot, it looks that you opened the developer tools with the Font tab on a SUMO page, does do you see the last resort font (?) at this forum as well ?

more options

Might be getting closer. Here's a new screenshot and might have identified the problem?

more options

Well, if Arial is broken, that's a lot of the web. Does Font Book show any issue with Arial?

Modified by cor-el

more options

OK, this is weird. I opened Font Book and validated the fonts. Arial came out ok. Then I ran Font Doctor, and it also found no issues. So, having noticed an 'install' box at the bottom of the Font Book validation window, I selected the Arial font groups and selected 'install,' figuring I had nothing to lose!

At first, I got the same result - all of those boxed question marks. Then I restarted the computer and somehow, it seems to be resolved! Now when I go to the Font Panel, it's all as it should be! (What an education!)

Thanks for directing me to all of the options. (Still not sure exactly what did it, but at least now I know where to look if it happens again.)

more options

(sorry... just kidding) Walked away and came back and I'm back to square 1. No clue.

more options

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Any difference in a private window -- that bypasses the browsing cache, in case that's a factor.

Assuming not, I wonder whether there is some mystery setting we aren't considering. Maybe try:

New Profile Test

This takes about 3 minutes, plus the time to test some problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2020 will remain available for future testing.)

IMPORTANT: Creating a new profile may change your default. If your regular profile has a Set as Default Profile button after this test, click that to make sure your next startup doesn't yield a surprise.

more options

Nope. That didn't work, either.

more options

Every time I try to reply, my accounts gets deactivated. But here's the third try!

I'm puzzled. Usually problems Firefox has reading built-in fonts on MacOS have been fixed via Font Book. ??

If it turns out to be necessary to work around Arial, there is a slightly involved way to do that, through custom style rules. These can be applied to pages using an extension like Stylus or an optional file named userContent. css. Stylus is nice because you can experiment and tweak quickly, while userContent. css is only read when Firefox starts up. Either way, the trick is to tell Firefox to use a different built-in font file in place of Arial.

I've put the rules in a separate file in case posting them here is what deactivates my account. There is an extra space after each . because of the link filter:

Since Windows doesn't come with an Arial font, I tested using Gill Sans MT instead, which yielded the attached screenshot for Google.

After installing Stylus, click its S button on the toolbar and click "Manage". Then click "Write new style". Give the style a name and paste the above style rule code, then click Save. Stylus should immediately apply the new rule to some open pages, but you also can reload pages to test the change.

Here's another broken link:

(fixed links, but this should work no - c)

Modified by cor-el

more options

I apologize for not responding sooner, but I just saw this. Thanks for this information. I will definitely try it, but it might not be for a few days. Will post the results either way.

more options

^^: It was the font-weight:800; rule that got you deactivated followed by at least 6 other digits elsewhere in the file (the filter strips out all characters that aren't digits).