Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons not working and other strange things upon updating to v. 77.0.1

  • 1 reply
  • 1 has this problem
  • Last reply by cor-el

more options

Upon updating to 77.0.1 my add-ons stopped working, including Facebook Container. The icons appear on the toolbar, but nothing happens when clicked. They all appear as "enabled" in the extension Manager. To solve this I found that I have to disable them all, then enable them again, without even exiting the manager. They will then work apparently fine until I close Firefox, then they all go back to being "disabled".

Also, I don't use tabs, I prefer opening separate windows. However, since the update I've found that if I open a second window, everything on the first window disappears, and the "go back one page" arrow is greyed out, so I have no option but to start all over and loose info.

If this is not solvable, is there a way I can go back to the previous version, which was working fine?

Thank you much!!

All Replies (1)

more options

You can check for problems with the extensions registry files in the profile folder.

Try to to reset the extensions registry and rename extensions.json (extensionsOLD.json) and rename/remove previously used extensions files like extensions.ini and extensions.sqlite when present and rename/remove compatibility.ini in the Firefox profile folder with Firefox closed.

New files will be created when required.

See "corrupt extension files":

You can check for possible updates in case of issues.

  • click the cogwheel button (left of the Search bar) on the about:addons page to "Check for updates"

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.