Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot connect to google or youtube in private mode but can in normal mode. help?

more options

all I get is that firefox cannot connect because

Hmm. We’re having trouble finding that site.

We can’t connect to the server at www.google.com.

If that address is correct, here are three other things you can try:

   Try again later.
   Check your network connection.
   If you are connected but behind a firewall, check that Firefox has permission to access the Web.

i have tried deleting cache and certain cookies but still nothing. i can connect in normal browsing and via private browsing in edge. please help? i have no idea what is causing this issue.


everything is up to date on my computer and so is firefox

a workaround that worked temporarily was via duckduckgo and clicking google after searching for it and now that no longer works

i have ublock origin installed but that does not seem to affect google when turning it off and back on

also youtube in normal browsing is no longer loading images or thumbnails. please help

Modified by IneedhelpwithFirefox

All Replies (2)

more options

Hi, that's very puzzling.

Usually your regular windows and your private windows connect in an identical manner, the only difference being that private windows do not save history to disk and may filter out more content in pages. Those shouldn't affect the connection to request the initial page.

Are you using any connection related add-ons, such as VPN extensions, that are active in regular windows but not in private ones? You can check on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading. Your extension should be listed below this heading.

An extension has permission to run in private windows if there is a purple mask icon next to its name. If there isn't and you want to grant permission, click its name to show the Details panel. Then scroll down to the settings area (below the description) where you'll find this row and you can make changes if needed:

Run in Private Windows                           (_) Allow (*) Don’t Allow
When allowed, the extension will have access to your online activities 
while private browsing. 

Otherwise, hmm.

Helpful?

more options

HI thanks for the reply, I still have no idea what caused it. I had to shut down my computer and turn it back on. Still have no idea what caused the issue. I do have my extensions allowed in private mode but before and after the problem, it did not affect browsing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.