Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

screen size on opening windows out of bounds (too large) ever other time I open firefox

  • 2 replies
  • 1 has this problem
  • 39 views
  • Last reply by cor-el

more options

windows 10 I open firefox in full screen mode, ever other time I start firefox the screen size is too large and the top of the screen show only the bottom half of the internet address line. The tabs and "X" to close the window are off the top of the screen. F11 only make it worst. I can fix it by doing a reset, but the problem keeps coming back, a day or 2 later. My only recourse is to close firefox from the windows 10 task bar - right click and select close. Then reopen firefox and all is good. Next I open firefox screen too big again.

windows 10 I open firefox in full screen mode, ever other time I start firefox the screen size is too large and the top of the screen show only the bottom half of the internet address line. The tabs and "X" to close the window are off the top of the screen. F11 only make it worst. I can fix it by doing a reset, but the problem keeps coming back, a day or 2 later. My only recourse is to close firefox from the windows 10 task bar - right click and select close. Then reopen firefox and all is good. Next I open firefox screen too big again.

All Replies (2)

more options

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved
You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window