Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox corrupt dropdown URL Menu error

  • 7 replies
  • 1 has this problem
  • 16 views
  • Last reply by pcbugfixer

more options

G'day Folks,

I have this problem with the drop down of the URL menu which shows 8 Asian URLs which I cannot delete or I don't know how to get rid of them.

I would like some help in rectifying this ASAP please

I have attached an image showing the corrupt drop down

Regards Roger H.

Attached screenshots

Chosen solution

Hi Roger, is this the list that appears when the cursor moves into the address bar, even before you've started to type anything for Firefox to match?

Starting in Firefox 75, Firefox automatically drops down a list of your first 8 "Top Sites" from the Firefox Home / new tab page when the cursor enters the address bar. To modify this list, you need to actually go to the new tab page and unpin unwanted sites, rearrange, add new ones, etc.

See: Customize the New Tab page

Alternately, if you don't want that list but instead your own history -- the classic list of frequently visited URLs -- you can disable the Top Sites section of the new tab page. You can do that on the Options page.

See: Hide or display content in New Tab

Was that the cause of that list?

There's still a mystery as to why those would be on the Top Sites list, unless you share your Firefox with someone who browses those sites.

Read this answer in context 👍 1

All Replies (7)

more options

Let's start with:

If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.


[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

When done, copy and post the results here.

https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional

Helpful?

more options

Click in the field. Using the arrow keys, highlight an unwanted entry.
Then press Shift > Delete Repeat as needed.

Helpful?

more options

FredMcD reply to your 1st message Places Database Integrity -> Image attached

Suggestion in your 2nd message did not work

Regards Roger H.

Helpful?

more options

FredMcD

posted attached full image.

Regards Roger H.

Helpful?

more options

Hello pcbugfixer,

FredMcD   asked me to tell you that due to certain circumstances, he can't post anything on the support forum right now.

Helpful?

more options

Chosen Solution

Hi Roger, is this the list that appears when the cursor moves into the address bar, even before you've started to type anything for Firefox to match?

Starting in Firefox 75, Firefox automatically drops down a list of your first 8 "Top Sites" from the Firefox Home / new tab page when the cursor enters the address bar. To modify this list, you need to actually go to the new tab page and unpin unwanted sites, rearrange, add new ones, etc.

See: Customize the New Tab page

Alternately, if you don't want that list but instead your own history -- the classic list of frequently visited URLs -- you can disable the Top Sites section of the new tab page. You can do that on the Options page.

See: Hide or display content in New Tab

Was that the cause of that list?

There's still a mystery as to why those would be on the Top Sites list, unless you share your Firefox with someone who browses those sites.

Modified by jscher2000

Helpful?

more options

jscher2000

Good job and thanks

"Hi Roger, is this the list that appears when the cursor moves into the address bar, even before you've started to type anything for Firefox to match? "

Answer = Yes

the new tab page and unpin unwanted sites, rearrange, add new ones, etc.

Answer= did this and got rid of them - Thanks

Was that the cause of that list?

Answer = I think so but really don't know what caused these URL's in the first place ☺

Thanks again for your help and fixing my problem.

Regards Roger H.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.