Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox / "consent.exe" crashing in infinite loop on startup

  • 1 reply
  • 1 has this problem
  • Last reply by Shiwa

more options

I have had the following issue 5 times now over a longer period of time (Windows 10, Firefox 77.0.1 and earlier versions).

Rarely, when I want to start Firefox, I get stuck in an infinite loop. The mouse cursor changes to a "loading" cursor and starts flickering forever, trying to start Firefox. This is bad enough for my whole system to behave strangely, e.g. mouse clicks will randomly not register or release.

Upon inspecting the task manager, I find that `consent.exe` repeatedly pops up and disappears. I assume it crashes and then firefox tries to restart, repeating in an infinite loop ... I only recently found a dubious/hacky way to stop this without logging out or restarting my pc: When I forcefully rename `C:/Windows/System32/consent.exe` via console, e.g. to `.../consent.exe_`, Firefox will crash "properly" with an error message and I can rename it back.

I have no idea what this `consent.exe` does or why it is called, which makes finding the cause or fixing the issue very hard..

Details / attempted fixes

The most recent time I had this issue, it appeared after trying to open an external link while Firefox was open. Firefox then found a new update and started automatically updating to the newest version (77.0.1), before trying to open the link and giving an error message (I don't remember what it was..). To properly apply the update I closed Firefox, tried to open it again, and I started getting this infinite crash loop.

This is not the first time I had this exact same issue, but the cause seems to vary. The first time I encountered this was back when there was a buggy Windows update, which if I read my logs correctly seems to have been at the end of February 2020. As far as I can remember at this time, the issue appeared immediately after restarting my PC and updating Windows (no opening of external links involved). The only way I managed to fix it was by uninstalling that Windows update. I disabled the following updates for some months. At this time I assumed the cause was the buggy Windows update, but since then I had the same issue 4 more times. Of the times I can remember the issue appeared immediately after

  • updating windows
  •  ??
  •  ??
  • clicking an external link
  • clicking an external link > automatic Firefox update > restart Firefox > crash

Every time I got this issue I tried many things to fix it, including

  • restarting Firefox
  • restarting the PC
  • deleting my Firefox profiles in `%AppData%\Mozilla\Firefox\Profiles` and `%AppData%\..\Local\Mozilla\Firefox\Profiles`

none of the above worked any time I had this issue - nonetheless the issue would disappear randomly without me knowing what fixed it.

The first time when it was seemingly caused by the buggy Windows update, I even uninstalled and reinstalled all of Firefox, including deleting my Profiles in AppData. Even then, the issue persisted on a completely clean and barebone install of Firefox. However, since then it is seemingly caused by opening external links and the problem always randomly disappeared before I got to try a clean Firefox install.

The most recent time, the issue disappeared while I was trying `firefox.exe --version`, `firefox.exe --help` to find out my Firefox version (I don't know the correct commands, so nothing happened). This did not work, but when I then tried to start Firefox again, I got about 10 or so error messages on the first attempt (unfortunately, I don't remember the error message..), and then the issue was gone on the second attempt to restart Firefox.

One other random guess I have is that some of my about:config settings may be related, in particular I completely disabled any links from opening popups, be it a new tab or window. But this sounds really like a bug and I certainly do not want to undo this setting.

In the end I am not even sure if this is a Firefox or Windows issue, and I am also not sure what would be a better place to look for support. Should I submit the above as bug report?

I am also very reluctant to try to reproduce the issue since I have no idea what the fix is and spent hours on it every time.

Modified by Shiwa

All Replies (2)

more options


more options

I reply after some months, as I just got the same issue once again after opening a link via script. Again to clarify, this exact same method worked many times since this issue occured some months ago, today for some seemingly random reason it decided not to.

To be specific: while firefox was open, I ran a script, which simply does "Run <some_url>" which opens in the default browser (firefox). Except it did not open (again, same script worked many times over the past months), and put my cursor into the infinite-load/crash-loop as described in my first post.

Thanks @FredMcD for the tip to try fix corrupted files, I tried this exactly as described in, but the output of the last command was "Windows Resource Protection did not find any integrity violations.", and it did not help.

So again began my attempt at fixing this issue with basically zero information what is going on .. thankfully I fixed it rather quickly this time, but again I do not know which of the steps, if any at all, were the crucial ones. Since I played around with renaming constent.exe the last times, I thought I can somehow "fix" it with similar steps. Here is what I did this time as soon as the issue appeared:

1) close firefox & all other programs 2) rename consent.exe to force it to crash 3) restore consent.exe to original name 4) restart pc 5) try to start firefox -> issue not fixed, appeared again 6) repeat steps 1-4 7) this time, rename consent.exe before trying to start anything 8) try starting other programs to check if they work, namely the Mail app & google chrome. No issues, they work. 9) Try to start firefox (consent.exe is still renamed so cannot be found) -> I get an error as expected, reporting that "firefox.exe" (which I just clicked on in the firefox installation directory) could not be found. Ok .. weird error? 10) Rename consent.exe back to original name 11) Try to start firefox -> from here on it works again

Again I do not know which or if any of these steps were necessary. Unfortunately "Consent.exe is a file of Windows operating system that has administrator-level access to files and settings" does not help me much, I guess I do not know enough about how the OS starts the program and/or what steps of it are specific to firefox, as other programs seem to work even if consent.exe does not exist.

Since as far as I can tell no system files are broken, the only possibily I can think of is that there is some buggy "state" flag/variable/setting of some sort that causes the issue. But I do not know where this could be. As described in my first post, I did try reinstalling firefox, so it could not be in the installation dir. I also tried deleting my profile directories, so it could not be there either. The registry is the only other place I know that stores any settings, but I have no idea what to look for in here.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.