Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't save files with flatpak version on linux

  • No replies
  • 1 has this problem
  • 7 views
more options

I'm running CentOS 7.8 at work and I prefer to use Firefox. However, the problem is that with CentOS, and being a work machine, Firefox doesn't normally come with codecs needed to play many online videos (such as on twitter) and my company won't install them. Having said that, the recent flatpak version of Firefox seems to have them bundled, so I installed that in user space.

It's great, except whenever I need to save a file I run into a problem. I've tried this in both KDE (4.14.8) and MATE. When the file dialog opens to save the file it doesn't have a save button, but an "Open" button instead. When I click the open button, with the default filename filled in that I'm trying to download, I get a kernel error pop up that says: "A problem has been reported in the xdg-desktop-portal-1.0.2-1.el7 package has been reported." I cant' investigate more because it wants root/sudo access to fully read the message. This happens every time I try to save anything, it's not intermittent, I'm unable to download anything. It didn't happen in the beginning, it just started a few weeks ago.

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.