Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

sign up via google not working

  • 4 replies
  • 5 have this problem
  • 113 views
  • Last reply by notralph

more options

I cant sign up/in to a website via my google account. Whats might have gone wrong? could you please help?

Thanks & Regards,

All Replies (4)

more options

I have this same problem. It used to work normally before. Was there any update breaking this feature? Once the "Sign in with Google" button is clicked, a new tab opens up where the Google session is authenticated, it asks to enable permissions for that app but then the tab closes and the app remains in the sign in page.

more options

I have the same problem. Two days ago everything was fine, and yesterday I could not sign into my gogle account. I can sign in through Chrome, though, so it's a firefox problem. When I try to sign in the answer is: "This browser or app could not be secure". I have Windows 10 and the latest Firefox release. So, what's worng?

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Tried all that above. Google does not allow sign ins using containers. Need fix asap. Why have containers if they ain't going to work to isolate sites?