Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

VPN is detecting P2P protocol use whenever Firefox opens

  • 6 replies
  • 1 has this problem
  • 143 views
  • Last reply by jamesbcad

more options

I'm having a novel problem today for the first time. Firefox is apparently using a p2p protocol, and I have no idea why. My VPN is detecting this whenever I open Firefox. I disabled all extensions, tried opening Firefox's safe mode, and it doesn't matter what tab is open. Brave browser doesn't give me this problem. My VPN's servers do not allow P2P use, so this is a big deal. Why would Firefox be setting off the p2p alarm, and how can I fix this? I'm using the newest Firefox version on windows 10.

All Replies (6)

more options

What are your connection/proxy settings (Preferences/Advanced)?

On Windows, the default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

If WebRTC is involved, see: https://www.reddit.com/r/firefox/comments/8hjh3h/google_voice_psa_if_you_have_been_recently_having/

Helpful?

more options

I tried disabling 'use system proxy settings' in Firefox, and turned off the 'automatic' proxy setting in Windows. I don't use WebRTC. Still having the same problem.

Modified by jamesbcad

Helpful?

more options

Hi jamesbcad,

Sometimes refreshing browser can fix many problems.

Try Refreshing your Browser:-

  • To do this, click the menu button at the top right corner of the Firefox window.
  • Click the “Help” option near the bottom of the menu.
  • Click the “Troubleshooting Information” option in the Help menu.
  • Click the “Refresh Firefox” button at the top right corner of the Troubleshooting Information page.
  • You’ll be warned that this will remove your browser add-ons, reset your customizations, and revert other browser data to the default settings. Click “Refresh Firefox” to confirm you want to make these changes.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Helpful?

more options

I tried that, and it doesn't fix the problem. I still get an error from my VPN app saying that P2P is being used. I'm using Brave now with no problems, but would really like to get this issue resolved with Firefox.

Helpful?

more options

For your solution Please visit this link https://bugzilla.mozilla.org/show_bug.cgi?id=726211

Helpful?

more options

I ended up uninstalling Firefox, deleting the Mozilla folder, then reinstalling Firefox. The problem didn't come back with the new installation. I still don't know why or how firefox was trying to use P2P connections. I suspect some kind of malware got into it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.