Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

icons fro Add-ons on the toolbar

  • 5 replies
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

with the installation of Firefox 77 all the icons for add-ons have disappeared from the toolbar and I cannot restore them. I can't easily use their features nor tell if I am in Private Browsing mode. Help

All Replies (5)

more options

Hello barrut,

An update -- I solved the problem, it turned out my secondary hard drive (where my Windows AppData folders are located) was failing, which kept disconnecting Firefox from my profile data). I have since replaced the drive and reinstalled Firefox, now the plugins work perfectly well.

Thank you!

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

more options

I'm afraid that doesn't help. The hard disc on the computer is working perfectly well.

Helpful?

more options

Your search bar is huge and seems to have eaten up all the available space, forcing everything else onto the overflow list (the >> icon). Or maybe I should blame the address bar, but I can't really get a sense of its current size...

You could try using the "Restore Defaults" button on the Customize tab. See: Customize Firefox controls, buttons and toolbars . It's at the bottom a little off center. But I'm not sure that will help.

The relative sizes of the address bar and search bar are stored in a file that sometimes becomes corrupted. Since it is difficult to edit, we generally suggest hiding it from Firefox so that Firefox generates a new one with default dimensions. Here's how.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

*    "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Any improvement?

This procedure will hide the Menu Bar and Bookmarks Toolbar. To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

   right-click a blank spot on the tab bar (or the "+" button)
   tap the Alt key to activate the classic menu bar > View > Toolbars
   in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars) 

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list.

Helpful?

more options

You can enable or disable extensions to work in private browsing mode via the about:addons page.
you see a purple mask when you enable the extension in PB mode.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.