Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

remove the One-Click Search Engines in about:config

  • 12 replies
  • 1 has this problem
  • 17 views
  • Last reply by Mike Kaply

more options

Hi

How can I remove the One-Click Search Engines in about:config see attachments

Thanks

Attached screenshots

All Replies (12)

more options

HI Mister-X, when you check/uncheck a one-click search engine on the Options page, or use the Remove button below the list, your choices are stored in a separate file called search.json.mozlz4 instead of prefs.js. The about:config page doesn't show settings from or allow changing settings in search.json.mozlz4.

Is there a problem with making the changes through the Options page?

Or did you want a Policy approach to removing search engines? Since the built-in search engine plugins are implemented as extensions, you can "uninstall" them to deactivate them.

This article describes how you create a Policy file: Customizing Firefox Using policies.json.

The contents of the policies.json file would be along the following lines:

{
  "policies": {
    "Extensions": {
      "Uninstall": [
        "amazondotcom@search.mozilla.org",
        "bing@search.mozilla.org",
        "ebay@search.mozilla.org",
        "twitter@search.mozilla.org",
        "wikipedia@search.mozilla.org"
      ]
    }
  }
}

As you can see, the list contains the search extension IDs you want to remove, separated by commas. (Writing them on separate lines is merely cosmetic.)

Helpful?

more options

Hi jscher2000

thanks for your reply, I already have an entry in policies.json, how can I add a second one ?

{

 "policies": {
   "Bookmarks": [
     {

"Favicon": "test",

       "Placement": "toolbar",
       "Title": "text",
       "URL": "https://google.com"
     }
   ],
   "DisplayBookmarksToolbar": true
 }

}

   "Extensions": {
     "Uninstall": [
       "amazondotcom@search.mozilla.org",
       "bing@search.mozilla.org",
       "ebay@search.mozilla.org",
       "twitter@search.mozilla.org",
       "wikipedia@search.mozilla.org"
     ]
   }
 }

}

Helpful?

more options

Does this work? Yours had some extra } characters:

{
  "policies": {
    "Bookmarks": [{
      "Favicon": "test",
      "Placement": "toolbar",
      "Title": "text",
      "URL": "https://google.com"
    }],
    "DisplayBookmarksToolbar": true,
    "Extensions": {
      "Uninstall": [
        "amazondotcom@search.mozilla.org",
        "bing@search.mozilla.org",
        "ebay@search.mozilla.org",
        "twitter@search.mozilla.org",
        "wikipedia@search.mozilla.org"
      ]
    }
  }
}

Helpful?

more options

no, One-Click is still there

Helpful?

more options

jscher2000's solution is working great for me.

Are there any errors in about:policies?

Helpful?

more options

please check the attachments

Helpful?

more options

What version of Firefox are you using? Are you using the ESR?

Helpful?

more options

I have 76.0.1 x64

Helpful?

more options

I'm at a loss. That exact same JSON is working for me.

Are there any errors on the JS console (Ctrl+Shift+J)

Helpful?

more options

Try to delete search.json.mozlz4 in the profile folder to see if that has effect.

Helpful?

more options

still the same problem

Helpful?

more options

I'm at a loss. This is working for me locally.

Note we do provide an official policy for this but it is ESR only.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.