Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

cannot get access to passwords

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by Andrew

more options

i update to version 76 and can no long access my passwords, keep getting messages enter pin. i got a recovery but enter , ff will NOT accept it, to to refresh, nothing works changed password password, still not able to access passwords i am locked out, and nothing i do helps, i have read all the notions but again nothing s works. TRIED TO DELETE ACCOUNT AND START OVER BUT WILL NOT ACCEPT PASSWORD. how can i fix this???? been using ff for about ten years this is ridiculous. . what is the sense of having a recovery key if it does not help get a recovery. please help AllenMillner

All Replies (1)

more options

Chosen Solution

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.