Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

reply uses wrong from email address

  • 7 replies
  • 1 has this problem
  • 26 views
  • Last reply by stevejq

more options

I have nine email accounts configured in Thunderbird. For some accounts, when I Reply the reply message uses the correct From email address, i.e., the email address to which the incoming email was addressed. For other accounts, the reply message From field is evidently a default email address that is configured somewhere in Thunderbird.

How can I configure Thunderbird to consistently use the address to which incoming email is sent in the From email address of a reply?

Thanks.

All Replies (7)

more options

It's recommended to have each account send through an smtp server with the same User Name as the sending account, not through a Default smtp. Some services, like gmail, will switch out the sending address for the gmail address if the sending address isn't a 'registered' account.

Open Tools/Account Settings, select an account in the left pane, then click Edit SMTP server... in the lower right pane. Does the User Name of the selected smtp match the User Name for the account? If not, select the correct one in the Outgoing Server (SMTP) drop-down. If extra smtp servers have to be created, select Outgoing Server (SMTP) at the bottom of the left pane. Give each smtp a distinct Description to make it easy to match accounts with smtp servers.

Helpful?

more options

Hello sfhowes. Thanks for the info about outgoing servers.

I have only one outgoing server for my nine email accounts. This afternoon I tested all of those accounts by replying to a received message for that account. The reply message's From email address was correct for every account. I'm just coming to realize that erroneous From email addresses is a "sometimes" thing.

I have created an outgoing server for my most used email account. I often have the wrong From email address when replying to incoming emails to this address. I'm going to observe for a few days to hopefully confirm the issue is resolved.

Appreciate the help.

Helpful?

more options

This evening I had occasion to reply to an email received in my Email3 account. The reply email consistently put Email0 in the From field.

The Email3 account had no outgoing SMTP server. So I created an outgoing SMTP server with Email3 as the user. No help. A reply from Email3 continues to choose Email0 as the From account.

So the problem persists. I would appreciate any further advice.

Steve

Helpful?

more options

I would check the passwords in Options/Security/Passwords/Saved Passwords, for both incoming and outgoing, to make sure all servers have the correct passwords. If passwords are removed, you'll be prompted to enter them when TB restarts. That might fix an account sending on the wrong server.

Helpful?

more options

I deleted passwords for all email accounts and reentered them as needed. I do not see a change in behavior with respect to the From email address when replying. Sometimes Thunderbird gets it right, often times not. Is there anything else to try? Thanks.

Helpful?

more options

Obviously, I am unable to check your setup in detail. All I can suggest is you follow the steps in my first reply and make sure each account is sending on an smtp with a matching User Name. It's not sufficient to just create a set of smtp servers - the correct server must be assigned to the relevant account.

Helpful?

more options

Thanks sfhowes.

"the correct server must be assigned to the relevant account" -- I looked through the server assignments and found a couple of errors. Made corrections. Now each account has its own server and is assigned to that server.

Perhaps these corrections will yield blue skies and singing birds. I will let you know.

Thanks for sticking with me.

Steve

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.