Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to remove the context menu on right click of min/max/close buttons?

  • 5 replies
  • 1 has this problem
  • 55 views
  • Last reply by ElementZero

more options

When I right click the min/max/close buttons in FireFox it pops open a context menu. I have a different program on my machine that uses right clicks of those buttons to do things, so I want to disable FireFox handling these. How do I do so?

Chosen solution

On Windows, by default, Firefox suppresses the normal top title bar, and simulates the Windows buttons on the right end of the Tabs bar. If you enable the Title Bar on the Customize tab, then you get the title bar with its real buttons. Not sure it's worth the sacrifice of vertical space but you could try it out:

Customize Firefox controls, buttons and toolbars -- the checkbox is at the lower left

Read this answer in context 👍 1

All Replies (5)

more options

Isn't that the standard system menu that opens via Alt+Space ?

Helpful?

more options

No, it only happens in FireFox. And the menu says "Bookmarks Toolbar" I attached a screenshot

Helpful?

more options

That is the standard toolbar menu. I don't think that there is a way to disable only the context menu and have the left-click still working.

Helpful?

more options

Chosen Solution

On Windows, by default, Firefox suppresses the normal top title bar, and simulates the Windows buttons on the right end of the Tabs bar. If you enable the Title Bar on the Customize tab, then you get the title bar with its real buttons. Not sure it's worth the sacrifice of vertical space but you could try it out:

Customize Firefox controls, buttons and toolbars -- the checkbox is at the lower left

Helpful?

more options

Ah ok. I guess it has to do that because the title bar serves as the tab bar as well. Makes sense. Guess there isn't really a way to solve it then (in the sense that I mean), but at least I know WHY it happens. I just thought it was some weird context menu thing.

Thanks a bunch!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.