Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird profile from another computer is not loading - error from console log included

  • No replies
  • 1 has this problem
  • 7 views
more options

I have the entire Thunderbird folder from another computer.

That profile had a number of accounts and lots and lots of folders and addresses and also used the lightning calendar (I believe). The profile was being actively used late last year on the old computer.

I am uncertain which version of Thunderbird was running on the old computer and I no longer have access to that computer. (As an aside, it might be helpful if there is a way to discover the Thunderbird version that last wrote to the profile. Anyone know of a way that I can discover this?)

I am attempting to use the profile from the old computer.

I have done this kind of thing (copying profiles from one computer to another) quite a number of times over the years and have never had any issues.

I started by downloading the current Thunderbird and installing it. Then I started it up, stopped it, and substituted C:\Users\lbake\AppData\Roaming\Thunderbird (the newly created folder) with the old Thunderbird folder.

In the past, I've copied over the specific profile, but https://support.mozilla.org/en-US/questions/1284045 said to copy over the whole Thunderbird folder.

When I did this I received the "You have launched an older version of Thunderbird" dialog.

I googled and found that version 68 has some issues with older profiles, so I then downloaded version 60.9.0 and did the same thing (started up. disregarded the newly created Thunderbird folder. copied over Thunderbird folder from old Thunderbird install on old computer).

In each case I see none of the accounts, folders, address book, ... or anything shows when I open Thunderbird.

With a clean install of 60.9.0, I then replaced just the contents of the newly created profile folder (C:\Users\lbake\AppData\Roaming\Thunderbird\Profiles\zi3wsnpl.default) with the contents of the old profile I wish to use because replacing just the contents was suggested in https://support.mozilla.org/en-US/kb/profiles-where-thunderbird-stores-user-data#w_restoring-a-profile-backup.

Same thing. Nothing showing except a very pristine Thunderbird window.

I opened up the error console (Tools -> Developer Tools -> Error Console) and there are a number of errors shown.

Does anyone know how I might be able to fix my issue given the following error log?

Any help is greatly appreciated.

thanks Kenn

---

C:\Users\lbake\AppData\Roaming\Thunderbird\Profiles\zi3wsnpl.default\prefs.js:1: prefs parse error: unexpected character XML Parsing Error: syntax error Location: jar:file:///C:/Users/lbake/AppData/Roaming/Thunderbird/Profiles/zi3wsnpl.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D.xpi!/install.rdf Line Number 1, Column 1: install.rdf:1:1 1588507158806 addons.xpi WARN Profile contains an add-on with a bad or missing install manifest at C:\Users\lbake\AppData\Roaming\Thunderbird\Profiles\zi3wsnpl.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi, overwriting: Error: No ID in install manifest (resource://gre/modules/addons/XPIInstall.jsm:544:11) JS Stack trace: loadManifestFromRDF@XPIInstall.jsm:544:11 loadFromRDF@XPIInstall.jsm:839:25 loadManifestFromZipReader@XPIInstall.jsm:869:21 loadManifestFromZipFile@XPIInstall.jsm:917:26 loadManifestFromFile@XPIInstall.jsm:926:12 syncLoadManifestFromFile@XPIProvider.jsm:940:3 installDistributionAddons@XPIProvider.jsm:3112:27 checkForChanges@XPIProvider.jsm:3254:17 startup@XPIProvider.jsm:2196:25 callProvider@AddonManager.jsm:253:12 _startProvider@AddonManager.jsm:728:5 startup@AddonManager.jsm:892:9 startup@AddonManager.jsm:2981:5 observe@addonManager.js:63:9 1588507158857 addons.xpi-utils WARN Could not find source bundle for add-on default-theme@mozilla.org: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.initWithPath]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js :: parseDB :: line 474" data: no] Stack trace: parseDB()@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:474 syncLoadDB()@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:405 checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3289 startup()@resource://gre/modules/addons/XPIProvider.jsm:2196 callProvider()@resource://gre/modules/AddonManager.jsm:253 _startProvider()@resource://gre/modules/AddonManager.jsm:728 startup()@resource://gre/modules/AddonManager.jsm:892 startup()@resource://gre/modules/AddonManager.jsm:2981 observe()@jar:file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/omni.ja!/components/addonManager.js:63 1588507158860 addons.xpi-utils ERROR Failed to load XPI JSON data from profile: Error: Expected passed argument to contain a path (resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:182:11) JS Stack trace: DBAddonInternal@XPIProviderUtils.js:182:11 parseDB@XPIProviderUtils.js:481:24 syncLoadDB@XPIProviderUtils.js:405:9 checkForChanges@XPIProvider.jsm:3289:9 startup@XPIProvider.jsm:2196:25 callProvider@AddonManager.jsm:253:12 _startProvider@AddonManager.jsm:728:5 startup@AddonManager.jsm:892:9 startup@AddonManager.jsm:2981:5 observe@addonManager.js:63:9 Log.jsm:797 1588507158896 addons.xpi-utils WARN addMetadata: Add-on AutoResizeImage@gmail.com_0 is invalid: Error: Invalid addon ID: expected addon ID AutoResizeImage@gmail.com_0, found AutoResizeImage@gmail.com in manifest (resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1177:15) JS Stack trace: addMetadata@XPIProviderUtils.js:1177:15 processFileChanges@XPIProviderUtils.js:1529:23 checkForChanges@XPIProvider.jsm:3291:34 startup@XPIProvider.jsm:2196:25 callProvider@AddonManager.jsm:253:12 _startProvider@AddonManager.jsm:728:5 startup@AddonManager.jsm:892:9 startup@AddonManager.jsm:2981:5 observe@addonManager.js:63:9 permissions.sqlite is corrupted! Try again! Corrupted permissions.sqlite has been removed. OpenDatabase to permissions.sqlite is successful! While creating services from category 'profile-after-change', could not create service for entry 'calendar-backend-loader', contract ID 'service,@mozilla.org/calendar/backend-loader;1' 2020-05-03 21:59:20 gloda.datastore WARN Global database has been purged due to schema change. old version was 0, new version is: 30

Use of Mutation Events is deprecated. Use MutationObserver instead. calendar-widgets.xml:512:20 Lightning:Warning: Using guessed timezone

 Australia/Brisbane (UTC+1000).

This ZoneInfo timezone seems to match the operating system timezone this year. This ZoneInfo timezone was chosen based on the operating system timezone identifier "E. Australia Standard Time". calTimezoneService.js:800 Lightning:Couldn't find /freeassociation.sourceforge.net/Tzfile/Australia/Brisbane calTimezoneService.js:194 Unable to import saved passwords because some data has already been imported or saved. LoginImport.jsm:67 2020-05-03 21:59:23 mail.setup INFO Initializing setup wizard

2020-05-03 21:59:23 mail.setup INFO Email account setup dialog loaded.

2020-05-03 21:59:23 mail.setup INFO switching to UI mode start

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.loadVirtualFolders]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: LoadPostAccountWizard :: line 539" data: no] (unknown) 2020-05-03 21:59:27 mail.setup INFO Shutting down email config dialog

TypeError: addon is null[Learn More] XPIProvider.jsm:3373:36

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.