Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I search using FireFox?

  • 9 replies
  • 3 have this problem
  • 518 views
  • Last reply by FredMcD

more options

I can't search using FireFox. Whenever I search something, NO MATTER WHAT SEARCH ENGINE, it says, "Did Not Connect: Potential Security Issue".

Yes, in the screenshot I attached, it is doing that with Bing, but it happens with every single search engine.

All Replies (9)

more options

Chosen Solution

more options

Thank you so much! That solved the problem! Have an amazing day!

more options

Glad to help. Safe Surfing.

more options

That's amazing!!1 I have solved the same problem thanks to you!

more options

Good to hear. Safe surfing.

more options

FredMcD said

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own.

And what can I do if I don't use any of those security softwares? I use Windows Security.

This article section offers a solution for every other AV software except Windows Security.

I'm having this problem since yesterday, been up and down this and other external forums and nothing seems to work. Interesting thing is this is happening with the Google start page only. All other pages load fine, and even Google loads OK in Chrome and Edge, but not on Firefox.

I already tried clearing cache and cookies, uninstalling and reinstalling Firefox (clean, no add-ons) and nothing.

Attached is screen capture of the error I'm getting.

Please help!

more options

That shows a certificate problem.

  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

more options

Hello!

Issue is solved. I don't know if it had anything to do with it, but I uninstalled the Adblock Plus add-on and the problem disappeared. Google is now loading fine.

Perhaps someone might wanna have a look into that.

Thanks for feedback!

more options

Load the web page. After the page is loaded, click the AdBlock icon. Now select Disable on <website>. Reload the page.