Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox desktop browser stuck on endless launch loop

  • No replies
  • 1 has this problem
more options

To start, I am using Windows 10 and Firefox 75.0. I have recently reinstalled Firefox and have run into a problem that makes the program unusable. When launching the browser after installation, it will never open and instead get stuck endlessly closing and opening a process in task manager. It is also not possible to terminate the process without either restarting my computer or uninstalling, as it will give an error saying the process does not exist anymore. This also seems to open and close consent.exe in the system32 files endlessly. I've tried multiple previous versions of Firefox in order to try and mitigate this problem, but all of them encounter the same result. I've uninstalled, deleted all of my profiles, cleared all files in appdata, and even tried deleting registry files related to the browser, but the problem persists. A similar problem seems to have been encountered by another user, but their problem seemed to fix itself ( Firefox also doesn't seem to produce any errors with this issue, so I am unsure of what to do.

EDIT: As of this writing I figured out the problem. It turns out my user account control panel had been disabled and was trying to launch itself to verify permissions. My user account did not have full control over the application, hence UAC trying to activate. Changing my account permissions solved this problem.

Modified by dylanmccy