Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't show a particular characters on web page at times. Especially those at the beginning of new paragraphs.

  • 11 replies
  • 1 has this problem
  • 28 views
  • Last reply by GPS

more options

There are times, when loading pages, Firefox won't show a particular characters. This is an old problem, it has happened for maybe a year or so.

Attached screenshots

Chosen solution

the same font used for all of the text or is there a different font used for the missing character ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Read this answer in context 👍 0

All Replies (11)

more options

Hmm, I don't see any particular difference in the page source code between those lines:

Is the problem always with the capital letter "I" or just in this case? Puzzling.

Helpful?

more options

It happens on random letters and on random websites at random times. But at each instances when it did happen it restrict itself to one particular capital letters. I remember it happened a couple of times on my wifi landing page, instead of showing a button with "Log out" it showed " og out".

Helpful?

more options

Here it is again, this time it decided to discard the letter "M"

Helpful?

more options

Is this with all websites/pages, some, a few?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

It seems to have a mind of its own, days could pass without it showing itself on any site I viewed and it seems to choose random sites as the mood strike it. This is maybe the first time I ever saw it when opening youtube.

For the record I don't have hardware acceleration enabled and the cookie/cache explanation seems like a good one. I do have my doubts though cause I seem to remember it once or twice showed up on sites that I only just visited for the first time. Anyhow,I never been really bothered by it so much and has pretty much think of it as an endearing quirk of my firefox.

Helpful?

more options

Hello   GPS,

Your system details show that you have this extension installed :

"Firefox Pioneer 1.0 (pioneer-opt-in@mozilla.org)"

Would you please disable it (or remove it) to see if that could be the cause
of this weird phenomenon ?

For more information :

https://support.mozilla.org/en-US/kb/about-firefox-pioneer

Helpful?

more options

Chosen Solution

the same font used for all of the text or is there a different font used for the missing character ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

I disabled Pioneer and the phenomenon showed up some time after and hide some number one in the video duration. ^_^ I'll try and see whether specifying particular local font in the Appearance setting would do the trick.

Modified by GPS

Helpful?

more options

Seems like they were given the same color as the color use in the background. They showed up once I highlighted them

Helpful?

more options

Good work. You should contact their support.

Helpful?

more options

This is just for the sake of documenting this quirk. ^_^

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.