Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

'a web page is slowing down your browser' Anyone got a solution? This has started recently April 2020

  • 1 reply
  • 2 have this problem
  • 28 views
  • Last reply by FredMcD

more options

Updated to latest verion of Firefox in early April. Now the error message appears when I try to log into Marks and Spencer's web site. There's no way of clearing the message or of getting the site pages to download properly. I know this has happened in the past but this is a recent occurance. Help please

Updated to latest verion of Firefox in early April. Now the error message appears when I try to log into Marks and Spencer's web site. There's no way of clearing the message or of getting the site pages to download properly. I know this has happened in the past but this is a recent occurance. Help please

Chosen solution

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox ++++++++++++++++++++++++++++++++++++++ Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox ++++++++++++++++++++++++++++++++++++++ Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}