Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF Bug with Missing Bookmark Icons? Heres an easy fix.

  • No replies
  • 2 have this problem
  • 30 views
more options

My Firefox bookmark icons fail to load. Just a globe showing in toolbar. I did a clean install of firefox and upon importing my bookmarks backup via html some bookmarks failed to update their icon even though it was showing properly on the tab. Even with an identical address it would still be a globe. I tried everything from refresh, clear history, deleting and changing the name of favicons/places sqlite. Nothing worked. Again, this was a clean install. All other firefox sytem folders were also removed prior to re-installing. Program files, appdata, etc. all deleted prior to installing.

After trying some things with no luck I found out that If you import your firefox bookmarks to chrome and re-load the bookmarks in chrome the icon refreshed to the correct one. I did that for all missing icons. I then exported the bookmarks as html, but before I imported them back into firefox i completely removed history and all bookmarks once again, and then restarted firefox.

Once firefox opened I imported the bookmark html from chrome and sure enough it worked. The bookmark icons were back to normal. To test i reloaded the page and even restarted firefox and they were all still ok. There is def an issue in firefox that prevents bookmark icons from refreshing properly. Hopefully the team will take a look into this and get a patch to firefox.

I already fixed the issue but I wanted to post here to report my findings in case this was a bug? For some reason I couldnt create an account at bugzilla either so thats why I am also posting here.

Modified by arugula

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.