Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am getting this message: error: platform version 75.0 is not compatible with minVersion and max Version 74.0.1 What should I do?!

  • 1 reply
  • 1 has this problem
  • 35 views
  • Last reply by Eve

more options

i can not access firefox browser. The above message keeps popping up

All Replies (1)

more options

This answer seems to reveal the reason: https://support.mozilla.org/en-US/questions/1081110