Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Searches in the URL/search bar are sometimes redirected to semi-random site

  • 10 replies
  • 1 has this problem
  • 32 views
  • Last reply by cor-el

more options

For example, when I search for the text "sabre/xml" I land on https://www.sabre.com/xml which is a 404 page, but I did not want to go to any website other than my default search engine. Why does Firefox sometimes redirect my searches like that? How do I turn it off?

Edit I updated to version 75 from 74 and also tried on Ubuntu, same issue there.

Modified by Niklas

All Replies (10)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions.

Remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

more options

I have none of those extensions, I only use Altair GraphQL Client and Multi-account Containers

The problem still exists if I restart Firefox without extensions.

more options

Hi, Firefox is seeing the slash and thinking that you're attempting to type a url, so it attempts to take you to the relevant site.

There's several ways around this, like including the search in quotes, or putting spaces around the slash, or just not including the slash.

more options

1. It does not have a protocol 2. It does not have a TLD 3. It is not the most relevant search 4. I have never found this "relevant" site to be actually relevant (if you are correct @Standard8)

If I search on Google or DuckDuckGO (my default search engine) the redirected domain is almost never in the top three results. Why isn't it choosing the top result

But more importantly: Why am I required to jump through hoops to do regular searches, and how do I stop this?

more options

Something is wrong, so we need to find the problem.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

@Niklas, unfortunately this is a known issue in Firefox: https://bugzilla.mozilla.org/show_bug.cgi?id=1398567

At the moment, there's no other way to change that behaviour apart from with the workarounds (you can also prefix the search by `?`).

Note that when you type in, it does say it will visit the page rather than search. That obviously doesn't help much, but should offer a cue at least.

more options

When I enter 'sabre/xml' in the search bar (Google's search bar, in my case) I get search results, as expected.

When I enter "sabre/xml" in the address bar, it redirects (like I thought it would) to https://www.sabre.com/xml

And this is what I see (see screenshot) :

more options

@Niklas I've just been told this is one of the things on the roadmap that we are currently planning on fixing soon. I don't have an exact timescale at the moment, but it is on the list.

more options

Thanks @Standard8, I hope it is fixed soon because this is such a prominent and in-my-face thing I can't stop being irritated by it :/

more options

A possible workaround is to start a search by typing '@' and select the search engine with the cursor down key. You can place your preferred search engine at the top in "Options/Preferences -> Search". You can also assign a keyword to a search engine and use that keyword to initiate the search.