Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird messages have a wormhole into other programs

  • 5 replies
  • 1 has this problem
  • 33 views
  • Last reply by coffent

more options

Starting a few days ago, often when I open a message and display it maximized on one of my two monitors, there is a rectangular "wormhole" (not sure how else to describe it) near the top of the screen (see screenshot). Clicking anywhere in or above this region causes any program *underneath* to respond.

Once one message does this, then so does every other message. Maximizing the main Thunderbird window on this monitor causes it to (not)respond in the same way.

If I type alt-space then Restore the non-maximized window behaves normally.

Maximized windows from other programs (not Thunderbird) behave normally.

Message windows maximized on the other monitor behave normally.

Closing Thunderbird and reopening it does not help. The only way to stop the problem (until the next time it occurs) is to reboot the computer.

Attached screenshots

All Replies (5)

more options

Have you recently had a Windows 10 update? I've recently updated to Version 1909.


This is not a Thunderbird issue because TB works perfectly ok on one of your monitors, yet is running the same program on same profile.

Searching on google I located people experiencing identical issues when maximising certain programs. There has been an issue with this type of problem for a while. Long discussion here: https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/windows-10-multi-monitor-maximized-window/3c2042ef-73df-401c-9a59-65b347d4dbea?page=1

Some people stated some or all of the following helped to fix the issue:

  1. If using an AMD GPU - Launch the AMD software > Click settings > Click Display > Enable GPU Scaling for 1 or all monitors.
  2. Right click desktop, go to Intel HD Graphics settings. Select Display and then choose the option Scale Full Screen. Make sure the option Override Application Settings has the checkbox marked
  3. Another person said...Both monitors have 2 HDMI ports. Whenever I use HDMI port 1 - the issue occurred constantly. When I changed ports to HDMI2 the issue resolved itself.
  4. Auto Snap feature in the Multitasking settings - switch it off.
  5. Click on the Task View button on the task bar. When all the active windows appear, right-click on the one you are having problems with and select snap right or snap left to force a repaint of window.

Helpful?

more options

Thanks for your suggestion. I thought it could be a Thunderbird issue since I've observed the problem only for Thunderbird screens. As I said, other programs' screens maximized on that monitor, even when Thunderbird is having the problem, do not exhibit it.

I'm also running Windows 10 v. 1909.

My version of Intel Graphics (1.100.2727.0) does not have an option of "Scale Full Screen". However I changed the display option from "Maintain aspect ratio" to "Maintain display scaling" to see if that will help. I'll update this post in a couple of days.

Helpful?

more options

Changing the display option as noted above did not fix the problem, as I'm still getting it. Again, however, it is only Thunderbird screens that are affected.

Helpful?

more options

Sometimes a display issue can occur if the graphics driver is not up to date, but you are specifically stating everything is ok on one monitor but not on the other. There is only one Thunderbird program running and it works perfectly ok in one of your monitors as you state, so it is not a Thunderbird issue. Thunderbird does not change just because you choose a different monitor, but the computer setup can cause issues.

It is a problem with the display, but there could be several reasons for the issue or even more than one issue. I've listed several things to check. Ports, Cables, Scaling, Auto Snap etc. You need to check all of them. I mentioned AMD, but perhaps you use NVIDIA.

Do you have a different DPI scaling on your monitors or are they the same? Suggest you start by making sure the DPI scaling is identical for each monitor. Then Check the HDMI cable and ports to see if they work better via another port.

It would also be worth while asking about dual monitor display issues in tech forums and Windows 10 forums. https://www.lifewire.com/fix-second-monitor-troubles-4582593

Helpful?

more options

Thanks for the suggestions. I'm using the recommended (native) resolution on both monitors. I have had the monitors in place for years and the monitor cabling in place and unchanged for several months, and up until a couple weeks ago there has been no problem. I've made no changes in the display options in several months except for the one I mentioned in my 3/31 posting, which didn't help and just recently, turning Snap Windows from on to off, which didn't help either.

Shortly after my 4/02 posting a non-Thunderbird window also exhibited the problem, though this has happened only a single time. Nevertheless I now agree that the problem isn't exclusive to Thunderbird. Strangely, though, when one Thunderbird window exhibits the problem, all of them do, and non-Thunderbird windows do *not* exhibit the problem.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.