Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

only one page not loading

  • 4 replies
  • 1 has this problem
  • 28 views
  • Last reply by FredMcD

more options

I have a problem with realestate.co.nz . It shows up in the toolbar etc, but in the last few weeks, just a blank page. Every other website works 100% I am using a desktop PC. Windows 10 pro. and obviously Firefox. I tried clearing cookies, data etc etc. The site works on Chrome, but I HATE chrome... Can anyone help please?

All Replies (4)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

more options

Well, something went right. I did the safe mode test, which then took me to the Three Bar Open menu, to Help, to Restart With Add-ons Disabled. Was that correct? Seems to have fixed the problem anyway. Now, is there anything else that I need to do? Do I need to get out of Safe Mode? Will it all fail again when I turn my PC off tonight, and then on again tomorrow morning? Many thanks, Stay Safe FredMcD ✔

more options

However, I now notice that my addblocker is totally gone on all sites. Was that all part the original problem? I did try disabling it for the one in question..

more options

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.