Search Support

autoplay options have effect - cnn.com, etc

  • 7 replies
  • 1 has this problem
  • 23 views
  • Last reply by Robert

more options

I have never been able to get autoplay options to prevent blasting out audio when stumbling onto a malicious website like CNN. This is a major privacy problem as perhaps you don't want the world to know you are studying how to seek legal or medical help etc with audio blasting out at max level.

I don't know why this is so hard to manage since detecting loud audio isn't that difficult and it seems like browsers have all sort of hooks into media features of the operating systems they run on.

Can't firefox take samples of the audio (we don't need advanced signal processing here), determine that it is blasting out, and kill it?

In any case I have never been able to get any impact from autoplay settings other than to screw up my browsing experience so bad I have to reset to defauts to even manually play a video.

Addins like no script are so restrictive they render browsing impossible.

All Replies (7)

more options

Hello Robert,

Block autoplay :

Would you do this please :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

media.autoplay.default and set its value to 2

Do the same with this preference :

media.autoplay.enabled.user-gestures-needed and make sure its value is set to true

And also :

media.block-autoplay-until-in-foreground and make sure it's value is set to true.

After you've made changes, close and restart Firefox.


Maybe you'd like to give this add-on a try :

https://addons.mozilla.org/firefox/addon/disable-autoplay/


Next thing you can do :

When you're on the site in question, click on the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Autoplay". Uncheck "Use Default" and check "Block Audio and video".

Then close and restart Firefox.

'Hope that does the trick .....

Helpful?

more options

I followed these instructions and it did not work on CNN.com

Helpful?

more options

Robert said

I followed these instructions and it did not work on CNN.com

There is one thing I haven't mentioned - would you take a look at this article and scroll down to the section :

"Autoplay site settings list "

Helpful?

more options

Yes.. I saw that based on earlier search. What I have found is that on CNN and other sites the settings inconsistently work. Most of the time they do not and audio screams out, but occasionally they work and vid does not auto play. Why does Firefox make this so difficult? Is Mozilla afraid of angering CNN and fears counter measures? This is serious question because as someone with digital audio background this seems relatively easy to solve assuming you have API to grab some audio samples and measure the output level.

Helpful?

more options

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 5 [0:allow; 1:blockAudible; 2:Prompt; 5:blockAll]
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

Helpful?

more options

I think browsers do not do proper job of ad block because of the risk of counter measures from large corporations like CNN, all these complex controls could be integrated into single and simple solution. For example, CNN could refuse to send content to Mozilla based browsers...similar to how they refuse to serve up to private browsing or if you have cookies disabled. I will never be convinced it is complex technical problem and believe blasting audio is a very bad political concession that erodes trust and makes for painful experience.

Helpful?

more options

Hi all, none of the suggestions are working, some of them rendered media impossible to play on some sites, others had no effect. I believe we know how to solve this problems in a clean, universal way. I also understand the marketing pressure to let websites BLAST OUT CONTENT IN ALL AUDIO CAPS SO EVERYONE WILL KNOW YOU ARE LISTENING TO CNN AND HUFFINGTON POST OR FOX WHATEVER.

It annoys everyone when this happens and this continues to undermine the concept of secure browsing.

Why not take an audio sample, measure the power/energy of that sample by sum(x^2) and drop the level.

These blocking controls should NOT be buried in obscure settings that will eventually corrupt the browser, they should be upfront on the task bar. The fact that they are hidden tells me they aren't well tested or working right.

We need a creative solution against the #$U*holes who think blasting out robo-anchor Wolf Blitzer is cool. It isn't. For many reasons.

Modified by Robert

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.