X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Bookmarks don't work

Posted

Updated Firefox a couple of days ago and, since then, bookmarks don't work. Now on 74.0, 64-bit.

Bookmarks bar is visible and the bookmarks themselves contain the correct URLs. But when I click on a bookmark, nothing happens - page refreshes but does not go to the bookmark. Bookmarks *do* work in incognito mode.

Updated Firefox a couple of days ago and, since then, bookmarks don't work. Now on 74.0, 64-bit. Bookmarks bar is visible and the bookmarks themselves contain the correct URLs. But when I click on a bookmark, nothing happens - page refreshes but does not go to the bookmark. Bookmarks *do* work in incognito mode.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

More Information

Scribe 737 solutions 3533 answers

Hi, this may be caused by an extension. Unless you have specifically allowed extensions to work in Private Browsing, they are temporarily disabled. Extensions in Private Browsing.

Hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Hi, this may be caused by an extension. Unless you have specifically allowed extensions to work in Private Browsing, they are temporarily disabled. [[Extensions in Private Browsing]]. Hold down the Shift key when you start Firefox to start in Safe Mode. More - [[Troubleshoot Firefox issues using Safe Mode]]. If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions. ''If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!''
Was this helpful to you?
Quote

Question owner

I do not have any extensions enabled.

I do not have any extensions enabled.
Was this helpful to you?
Quote
Roland Tanglao
  • Administrator
77 solutions 847 answers

Hi elise:

Does surfing to websites work if you type in the URL and don't use bookmarks?

Cheers! ...Roland

Hi elise: Does surfing to websites work if you type in the URL and don't use bookmarks? Cheers! ...Roland
Was this helpful to you?
Quote

Question owner

Hi Roland,

It depends on the bookmark. Gmail and Outlook won't launch regardless (except in Private mode). Other sites can be navigated to as long as I type the URL.

I'm going to uninstall and reinstall Firefox.

Thanks!

Hi Roland, It depends on the bookmark. Gmail and Outlook won't launch regardless (except in Private mode). Other sites can be navigated to as long as I type the URL. I'm going to uninstall and reinstall Firefox. Thanks!
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17857 solutions 161589 answers

If you use a bookmark to access a specific page then instead navigate to this page starting with the main page or with the sign in page in case there is a problem with this bookmark. Best is to avoid bookmarking a page that links to a specific (numbered) server or has been requested via GET data or POST data from the server.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

If you use a bookmark to access a specific page then instead navigate to this page starting with the main page or with the sign in page in case there is a problem with this bookmark. Best is to avoid bookmarking a page that links to a specific (numbered) server or has been requested via GET data or POST data from the server. ----- You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data for that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.