X
Tap here to go to the mobile version of the site.

Support Forum

Forced Yahoo search every now and then

Posted

Hello

My Firefox is acting quite quirky, as every now and then when I search something via my adress bar it uses Yahoo instead of Google. I have checked my extensions and my search tools and Yahoo never shows up there. One example which happened just now was this: I searched "Carnaval meers 2020" in my adress bar and when I pressed enter, the following URL popped up in it, sending me to a Yahoo search request: https://nl.search.yahoo.com/yhs/search?hspart=dcola&hsimp=yhs-001&type=gsp_dventures_00_00_ag25764¶m1=1¶m2=cat%3Dweb%26sesid%3D8cdb1ceb996de63fe58d1805e1846a64%26ip%3D92.110.185.189%26b%3DFirefox%26bv%3D72.0%26os%3DWindows-10%26os_ver%3D10.0%26pa%3Dgencoll12%26sid%3D4175dbbf066e92669c742075ebdf60b6%26abid%3D21412%26abg%3D25764%26a%3Dgsp_dventures_00_00_ag25764%26sdk_ver%3D%26cd%3D%26cr%3D%26f%3D%26uref%3D&p=carnaval%20meers%202020

Any help would be much appreciated.

Hello My Firefox is acting quite quirky, as every now and then when I search something via my adress bar it uses Yahoo instead of Google. I have checked my extensions and my search tools and Yahoo never shows up there. One example which happened just now was this: I searched "Carnaval meers 2020" in my adress bar and when I pressed enter, the following URL popped up in it, sending me to a Yahoo search request: https://nl.search.yahoo.com/yhs/search?hspart=dcola&hsimp=yhs-001&type=gsp_dventures_00_00_ag25764&param1=1&param2=cat%3Dweb%26sesid%3D8cdb1ceb996de63fe58d1805e1846a64%26ip%3D92.110.185.189%26b%3DFirefox%26bv%3D72.0%26os%3DWindows-10%26os_ver%3D10.0%26pa%3Dgencoll12%26sid%3D4175dbbf066e92669c742075ebdf60b6%26abid%3D21412%26abg%3D25764%26a%3Dgsp_dventures_00_00_ag25764%26sdk_ver%3D%26cd%3D%26cr%3D%26f%3D%26uref%3D&p=carnaval%20meers%202020 Any help would be much appreciated.

Chosen solution

Before you submit the search, what does Firefox say it plans to do with your input? For example:

  • shows a URL and says "Visit"
  • says "Search with Google" (or other search engine)

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Chosen Solution

Before you submit the search, what does Firefox say it plans to do with your input? For example:

  • shows a URL and says "Visit"
  • says "Search with Google" (or other search engine)

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Before you submit the search, what does Firefox say it plans to do with your input? For example: * shows a URL and says "Visit" * says "Search with Google" (or other search engine) Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote

Question owner

Whenever I put something in, it always says "Search with Google".

After using Safe Mode for a few minutes, there haven't been any redirections to Yahoo. So it must be one of my Add-Ons, then?

Whenever I put something in, it always says "Search with Google". After using Safe Mode for a few minutes, there haven't been any redirections to Yahoo. So it must be one of my Add-Ons, then?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8961 solutions 73431 answers

Helpful Reply

That seems the most likely explanation. Redirects sometimes sneak into unrelated add-ons, unfortunately. Yesterday, someone on Reddit mentioned that "Ratings Preview for YouTube" has this problem, for example.

That seems the most likely explanation. Redirects sometimes sneak into unrelated add-ons, unfortunately. Yesterday, someone on Reddit mentioned that "Ratings Preview for YouTube" has this problem, for example.
Was this helpful to you? 1
Quote

Question owner

I do indeed have that Add-On! I'll keep it turned off until further notice.

Thank you so much.

I do indeed have that Add-On! I'll keep it turned off until further notice. Thank you so much.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.