X
Tap here to go to the mobile version of the site.

Support Forum

After upgrade to 73.0 some fonts are not rendering or cascading to next font-family definition like other browsers.

Posted

On my cPanel login page, the body font-family definition is being overridden by an inline style

body { font-family: "Gotham SSm A", "Gotham SSm B", "Gotham", Arial; }.

"Gotham SSm A", "Gotham SSm B", and "Gotham" are not defined elsewhere inline or any linked style sheet. Every other browser on my Macbook (OSX Catalina) displays the page with the body font as Arial, skipping over the Gotham variants. Firefox seems to be trying to find them or is displaying boxed ? marks in place of missing glyphs. It is a nuisance really, I can just not use Firefox or defeat the inline override for login page because it does not occur on cPanel once logged in. But the glitch is there and I would like to know where it is coming from if possible. Gotham font is present and active on my Macbook as well, but not Gotham SSm A and B (ScreenSmart)...

On my cPanel login page, the body font-family definition is being overridden by an inline style body { font-family: "Gotham SSm A", "Gotham SSm B", "Gotham", Arial; }. "Gotham SSm A", "Gotham SSm B", and "Gotham" are not defined elsewhere inline or any linked style sheet. Every other browser on my Macbook (OSX Catalina) displays the page with the body font as Arial, skipping over the Gotham variants. Firefox seems to be trying to find them or is displaying boxed ? marks in place of missing glyphs. It is a nuisance really, I can just not use Firefox or defeat the inline override for login page because it does not occur on cPanel once logged in. But the glitch is there and I would like to know where it is coming from if possible. Gotham font is present and active on my Macbook as well, but not Gotham SSm A and B (ScreenSmart)...
Attached screenshots

Modified by Keith Bloom

Chosen solution

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0

More Information

Question owner

[post deleted because edit applied to original question]

[post deleted because edit applied to original question]

Modified by Keith Bloom

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4398 solutions 61704 answers

Is this with all websites/pages, some, a few?


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Is this with all websites/pages, some, a few? Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
4398 solutions 61704 answers

Chosen Solution

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Was this helpful to you? 1
Quote

Question owner

So if I restart in safe mode and it fixes issue, does that mean one of the plugins is contributing or causing this issue?

So if I restart in safe mode and it fixes issue, does that mean one of the plugins is contributing or causing this issue?
Was this helpful to you?
Quote

Question owner

Disabling Hardware Acceleration seems to have solved it. When restarted, the login now comes in clean and finds the fonts as it should from system library.

Thank you FredMcD!

Disabling Hardware Acceleration seems to have solved it. When restarted, the login now comes in clean and finds the fonts as it should from system library. Thank you FredMcD!
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4398 solutions 61704 answers

Glad to help. Safe Surfing.


Keith Bloom said

So if I restart in safe mode and it fixes issue, does that mean one of the plugins is contributing or causing this issue?

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

Glad to help. Safe Surfing. ''Keith Bloom [[#answer-1290264|said]]'' <blockquote> So if I restart in safe mode and it fixes issue, does that mean one of the plugins is contributing or causing this issue? </blockquote> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.