X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

change the language

Posted

Hi Some times when I open Persian web sites my Firefox language is changing from English to persian . how can i stop this action and keep the language of menu and .... to English? I should manually change the language to English time by time.

Hi Some times when I open Persian web sites my Firefox language is changing from English to persian . how can i stop this action and keep the language of menu and .... to English? I should manually change the language to English time by time.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 8.0.0; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
944 solutions 7082 answers

Hi

If you open the Firefox for Android menu and select Settings, then General, followed by Language you will either be able to set the language as the same as your Android Device ("system default") or a different language from the list provided.

I hope this helps.

Hi If you open the Firefox for Android menu and select '''Settings''', then '''General''', followed by '''Language''' you will either be able to set the language as the same as your Android Device ("system default") or a different language from the list provided. I hope this helps.
Was this helpful to you?
Quote

Helpful Reply

Hi again I do not want to change the language. I prefer the language is fix in English. In setup I always select ( English ) no ( system default ). but almost Firefox will change the language by itself to persian when visit some persian websites so I forced to return it to English manually.

Hi again I do not want to change the language. I prefer the language is fix in English. In setup I always select ( English ) no ( system default ). but almost Firefox will change the language by itself to persian when visit some persian websites so I forced to return it to English manually.
Was this helpful to you? 1
Quote
Rasmus Kallas 4 solutions 38 answers

What is the website in question?

What is the website in question?
Was this helpful to you?
Quote
Shams 0 solutions 1 answers

I have the same problem and i temporally stopped using firefox because its annoying. Though i have selected English in option language setting and its showing that the default is English but whenever i open the firefox in my laptop it opens in Arabic.

I have the same problem and i temporally stopped using firefox because its annoying. Though i have selected English in option language setting and its showing that the default is English but whenever i open the firefox in my laptop it opens in Arabic.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.