Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some Tabs close randomly without me closing them?

  • 1 reply
  • 1 has this problem
  • 26 views
  • Last reply by crankygoat

more options

This has been happening over the last month or so. I'll be browsing with multiple tabs open and then for no apparent reason a few of my tabs will just close themselves. I'm not clicking on anything or using any shortcuts. Without any input on my part a group of maybe 3 or 4 tabs just suddenly close themselves, while the rest of my tabs remain. It doesn't seem to matter what pages the tabs are open to: google, amazon, whatever... Anybody have any ideas what's causing this? I've already tried updating, restarting, and disabling add-ons.

This has been happening over the last month or so. I'll be browsing with multiple tabs open and then for no apparent reason a few of my tabs will just close themselves. I'm not clicking on anything or using any shortcuts. Without any input on my part a group of maybe 3 or 4 tabs just suddenly close themselves, while the rest of my tabs remain. It doesn't seem to matter what pages the tabs are open to: google, amazon, whatever... Anybody have any ideas what's causing this? I've already tried updating, restarting, and disabling add-ons.

All Replies (1)

more options

Had you tried starting Firefox in Safe Mode? ☰ → Help → Restart with Add-ons Disabled (This actually does slightly more than turn off extensions.)

- You might try a clean profile, in the case that something broken in there is affecting your tabs: Type about:profiles in the address bar, and Enter. Click Create a New Profile Give it a name. Do not "choose folder" Click Finish Scroll to the new profile Click Launch Profile in new Browser Close the original browser window

You can also set the new profile as Default, in case you want to test across multiple sessions.

- As Firefox has moved to a multiprocess model, it may be something else killing processes. ☰Menu → Preferences → Performance section, untick the box for Use recommended settings → lower the content process limit (to 1, even) for testing.