X
Tap here to go to the mobile version of the site.

Support Forum

Quickbooks Online and other websites using menus no longer loading when clicking links - recent Firefox update. Only work in 'Private mode'

Posted

I am a Quickbooks Online user. Recently, my Firefox browser updated to 72.0.2 (64-bit). Now, after the update, when I attempt to go into my Quickbooks Online account and create a 'new' estimate or invoice, the menus work, but after clicking, nothing opens. I'm not very familiar with web design, but I believe they are Java based menus. If I click one of the links that directs to an outside website, they work fine. I've noticed the same thing on other websites, gemlux marine boat parts is another. Same thing, clicking in a menu does not open the link.

Lastly, when shopping on Amazon, if an item has an option (like sizes, colors, etc), and I click on the different size or color, it does not update the item page and price like it normally does. In other words, if I have a $20 item in size SMALL, and hit the drop down to change it to a size LARGE which should be $10 more, the price change does not show in Amazon's price menu. I found that if I click the 'large' in the drop down, leave it, and refresh the page, the page loads with the 'large' size selected, and then prices it correctly.

For whatever reason, if I switch to 'privacy' mode, it works fine.

I have used all of these websites frequently in the past year, and only in the last week has this started occurring. All of these websites work just fine in Chrome, IE, Edge, etc.

I prefer Firefox, so I'd like to get this figured out. It's probably something simple, like a Java setting...but that's over my head.

Thanks in advance Shawn

I am a Quickbooks Online user. Recently, my Firefox browser updated to 72.0.2 (64-bit). Now, after the update, when I attempt to go into my Quickbooks Online account and create a 'new' estimate or invoice, the menus work, but after clicking, nothing opens. I'm not very familiar with web design, but I believe they are Java based menus. If I click one of the links that directs to an outside website, they work fine. I've noticed the same thing on other websites, gemlux marine boat parts is another. Same thing, clicking in a menu does not open the link. Lastly, when shopping on Amazon, if an item has an option (like sizes, colors, etc), and I click on the different size or color, it does not update the item page and price like it normally does. In other words, if I have a $20 item in size SMALL, and hit the drop down to change it to a size LARGE which should be $10 more, the price change does not show in Amazon's price menu. I found that if I click the 'large' in the drop down, leave it, and refresh the page, the page loads with the 'large' size selected, and then prices it correctly. For whatever reason, if I switch to 'privacy' mode, it works fine. I have used all of these websites frequently in the past year, and only in the last week has this started occurring. All of these websites work just fine in Chrome, IE, Edge, etc. I prefer Firefox, so I'd like to get this figured out. It's probably something simple, like a Java setting...but that's over my head. Thanks in advance Shawn
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

RobertJ
  • Top 10 Contributor
136 solutions 1396 answers

Hi riggedrightmarine, It's probably more simple than a Java setting. Cookies, cache and site data are not carried over to a Private Browsing window from the "normal" window. Private Browsing is basically fresh.

Clearing cookies & site data should solve your problem. There are a number of ways to do this, depending on the circumstances, and you would probably only want to clear them out for a single site.

This article explains all of the details: Clear cookies and site data in Firefox https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox#firefox:win10:fx72

Hi riggedrightmarine, It's probably more simple than a Java setting. Cookies, cache and site data are not carried over to a Private Browsing window from the "normal" window. Private Browsing is basically fresh. Clearing cookies & site data should solve your problem. There are a number of ways to do this, depending on the circumstances, and you would probably only want to clear them out for a single site. This article explains all of the details: Clear cookies and site data in Firefox https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox#firefox:win10:fx72
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17759 solutions 160609 answers

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console what content is blocked.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console what content is blocked. *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.