X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Stop all update prompts

Les
Posted

I did write something descriptive, but this page a has a problem which has deleted my message after submitting: so first look at this page's code! Basically on 69.0.1 as 72.0.2 has basic flaw which slows up every new tab to ten seconds. Sick of updates not working. Have now include a 4 method block to prevent unwanted updates. Now I want to stop ALL nag screens. Websites advise about:config settings which don't exist.

I did write something descriptive, but this page a has a problem which has deleted my message after submitting: so first look at this page's code! Basically on 69.0.1 as 72.0.2 has basic flaw which slows up every new tab to ten seconds. Sick of updates not working. Have now include a 4 method block to prevent unwanted updates. Now I want to stop ALL nag screens. Websites advise about:config settings which don't exist.

Chosen solution

You can inspect the Mozilla and Firefox keys with the Windows Registry Editor in HKEY_LOCAL_MACHINE and possibly in HKEY_CURRENT_USER with the Windows Registry Editor to see whether GPO policy rules are active.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\

Note that the mere presence of the "MozillaFirefox" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\
Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

Wesley Branton
  • Top 25 Contributor
715 solutions 5635 answers

It's NEVER recommended to disable updates, since it can leave you vulnerable to serious security and privacy flaws (see a recent example).

However, if you really are willing to take the risk, you can disable updates using the DisableAppUpdate policy. This would be implemented either with a policies.json file or using Windows Group Policy.

Hope this helps.

It's <u>'''NEVER'''</u> recommended to disable updates, since it can leave you vulnerable to serious security and privacy flaws ([https://www.welivesecurity.com/2020/01/09/mozilla-rushes-patch-firefox-zero-day/ see a recent example]). However, if you really are willing to take the risk, you can disable updates using the <code>DisableAppUpdate</code> policy. This would be implemented either with [[Customizing Firefox Using policies.json|a policies.json file]] or [[Customizing Firefox Using Group Policy (Windows)|using Windows Group Policy]]. Hope this helps.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17860 solutions 161609 answers

You can check for problems with the sessionstore.jsonlz4 file in the Firefox profile folder that stores session data.

  • delete sessionstore.jsonlz4 and sessionstore.js

When sessionstore.jsonlz4 is deleted you lose pinned tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

You can check for problems with the sessionstore.jsonlz4 file in the Firefox profile folder that stores session data. *delete sessionstore.jsonlz4 and sessionstore.js When sessionstore.jsonlz4 is deleted you lose pinned tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Folder/Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles ---- If you use Sync then best is to disconnect Sync temporarily during troubleshooting. You can check for problems with the <b>places.sqlite</b> and <b>favicons.sqlite</b> files in the Firefox profile folder. *use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page In case errors are reported with "Verify Integrity" close and restart Firefox and retry. If "Verify Integrity" cannot repair places.sqlite, rename/remove all <b>places.sqlite</b> and <b>favicons.sqlite</b> files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder. *keep a backup copy of places.sqlite in case a new places.sqlite database has to be created See also: *https://support.mozilla.org/en-US/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Folder/Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles ----- Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect. *https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *https://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
Was this helpful to you? 0
Quote

Question owner

As the option is to update and screw up my internet use, or not, and remain satisfied, as an adult, I’ll stick with the latter option. If Firefox is that insecure then do something constructive about making it workable at the same time as making it safe! 10 seconds delay EVERY time I want to do something is unworkable. If it's that critical then why hasn't my phone and tablet been updated too?

I am still waiting for a repair for Roboform toolbar that is over a year coming, so I won’t hold out for any other repairs that may take as long as this!

I have used the json file this as part of the four way measures to prevent the app updating. This does nothing to stop the notifications!

As the option is to update and screw up my internet use, or not, and remain satisfied, as an adult, I’ll stick with the latter option. If Firefox is that insecure then do something constructive about making it workable at the same time as making it safe! 10 seconds delay EVERY time I want to do something is unworkable. If it's that critical then why hasn't my phone and tablet been updated too? I am still waiting for a repair for Roboform toolbar that is over a year coming, so I won’t hold out for any other repairs that may take as long as this! I have used the json file this as part of the four way measures to prevent the app updating. This does nothing to stop the notifications!
Was this helpful to you?
Quote
Wesley Branton
  • Top 25 Contributor
715 solutions 5635 answers

To clarify a few things, Roboform has nothing to do with Mozilla. It's developed by a third-party developer, so they are the ones that need to fix any problems.

As for the updates, they do usually include a substantial list of security fixes. Here's a list of the security issues fixed in Firefox 72.0, for example. There will always been new security issues that need to be fixed because there will always be bad people trying to exploit things.

To answer your other question, your phone and tablet are updated on the same schedule as the desktop version of Firefox. Firefox 72.0 on desktop and Firefox 68.4.2 on mobile were both updated on January 20. The only difference is that the version number on the desktop version of Firefox doesn't match the mobile version.

Finally, to answer you original question, assuming you have the policies.json configured correctly, you shouldn't get any update notifications. Firefox won't even check for updates when that policy is active. To check if you have it setup correctly, go to about:policies in Firefox and see if the policy to disable updates is listed as active.

To clarify a few things, Roboform has nothing to do with Mozilla. It's developed by a third-party developer, so they are the ones that need to fix any problems. As for the updates, they ''do'' usually include a substantial list of security fixes. [https://www.mozilla.org/en-US/security/advisories/mfsa2020-01/ Here's a list] of the security issues fixed in Firefox 72.0, for example. There will always been new security issues that need to be fixed because there will always be bad people trying to exploit things. To answer your other question, your phone and tablet ''are'' updated on the same schedule as the desktop version of Firefox. Firefox 72.0 on desktop and Firefox 68.4.2 on mobile were both updated on January 20. The only difference is that the version number on the desktop version of Firefox doesn't match the mobile version. Finally, to answer you original question, assuming you have the policies.json configured correctly, you shouldn't get any update notifications. Firefox won't even check for updates when that policy is active. To check if you have it setup correctly, go to <code>about:policies</code> in Firefox and see if the policy to disable updates is listed as active.
Was this helpful to you?
Quote

Question owner

DisableAppUpdate is there but not active, so this appears to be another rubbish workaround. So what should the file content be? {

"policies": {
   "DisableAppUpdate": true
 }

}

Roboform works correctly in Chrome, Opera and all forms of Internet Explorer. It doesn't work in Firefox due to them having their own interpretation of what should work and how. As Firefox insist on loading the bar at the bottom of the screen instead of at the top, you have to keep disabling it in order to use websites properly. For similar reasons I wanted to lock Firefox to a release where it still worked, but again Firefox found a way to bypass my settings.

DisableAppUpdate is there but not active, so this appears to be another rubbish workaround. So what should the file content be? { "policies": { "DisableAppUpdate": true } } Roboform works correctly in Chrome, Opera and all forms of Internet Explorer. It doesn't work in Firefox due to them having their own interpretation of what should work and how. As Firefox insist on loading the bar at the bottom of the screen instead of at the top, you have to keep disabling it in order to use websites properly. For similar reasons I wanted to lock Firefox to a release where it still worked, but again Firefox found a way to bypass my settings.
Was this helpful to you?
Quote
Scribe 737 solutions 3533 answers

Hi, unfortunately the about:config settings no longer work, and although many users - including me, would be happy to just stop or reduce the number of notifications, the only option available now is to completely disable updates. Did you do this? -

Close Firefox, then create a directory (folder) called distribution in the same directory (folder) as your Firefox executable.

Then create a file called policies.json and put it in that directory (folder), with the following pasted into it:

{

 "policies": {
   "DisableAppUpdate": true
 }

}


To check that it's enabled, type about:policies in to the address bar and press Enter.

As has been said, Roboform is nothing to do with Firefox, so we regrettably cannot help with that.

Hi, unfortunately the '''about:config''' settings no longer work, and although many users - including me, would be happy to just stop or reduce the number of notifications, the only option available now is to completely disable updates. Did you do this? - Close Firefox, then create a directory (folder) called '''distribution''' in the same directory (folder) as your Firefox executable. Then create a file called '''policies.json''' and put it in that directory (folder), with the following pasted into it: { "policies": { "DisableAppUpdate": true } } ---------------------------------------- To check that it's enabled, type '''about:policies''' in to the address bar and press Enter. As has been said, Roboform is nothing to do with Firefox, so we regrettably cannot help with that.
Was this helpful to you?
Quote

Question owner

As you will see, the details you have provided me are exactly as those used. This doesn't work!

As you will see, the details you have provided me are exactly as those used. This doesn't work!
Was this helpful to you?
Quote
Wesley Branton
  • Top 25 Contributor
715 solutions 5635 answers

If you go to the about:policies page in Firefox and select Active, if the DisableAppUpdate policy listed there?

If not, a common thing that happens is that people have actually saved the JSON file as a text file. On certain text editors (Windows Notepad especially), a .txt file name extension is added to the end. This often means the file is called policies.json.txt, but since many operating systems hide the file name extension by default, it may still appear in the file browser as policies.json.

A good way to check this is to show file name extensions. On Windows 10, you do this by clicking View in the Windows file explorer and then checking the File name extensions option.

If the file is called policies.json.txt or anything other than policies.json, rename it to the correct name. If renaming the file involves changing the file extension, you may get a warning message about potentially damaging the file. You can disregard that in this case.

Hope this helps.

If you go to the <code>about:policies</code> page in Firefox and select '''Active''', if the <code>DisableAppUpdate</code> policy listed there? If not, a common thing that happens is that people have actually saved the JSON file as a text file. On certain text editors (Windows Notepad especially), a <code>.txt</code> file name extension is added to the end. This often means the file is called <code>policies.json.txt</code>, but since many operating systems hide the file name extension by default, it may still appear in the file browser as <code>policies.json</code>. A good way to check this is to show file name extensions. On Windows 10, you do this by clicking '''View''' in the Windows file explorer and then checking the '''File name extensions''' option. If the file is called <code>policies.json.txt</code> or anything other than <code>policies.json</code>, rename it to the correct name. If renaming the file involves changing the file extension, you may get a warning message about potentially damaging the file. You can disregard that in this case. Hope this helps.
Was this helpful to you?
Quote

Question owner

Not showing as active. Saved a json file, see attached.

Not showing as active. Saved a json file, see attached.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17860 solutions 161609 answers

Chosen Solution

You can inspect the Mozilla and Firefox keys with the Windows Registry Editor in HKEY_LOCAL_MACHINE and possibly in HKEY_CURRENT_USER with the Windows Registry Editor to see whether GPO policy rules are active.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\

Note that the mere presence of the "MozillaFirefox" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\
You can inspect the Mozilla and Firefox keys with the Windows Registry Editor in HKEY_LOCAL_MACHINE and possibly in HKEY_CURRENT_USER with the Windows Registry Editor to see whether GPO policy rules are active. *HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ Note that the mere presence of the "MozillaFirefox" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty. *HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =><br>HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\
Was this helpful to you? 1
Quote

Question owner

The registry fix worked, thanks. Problem solved.

The registry fix worked, thanks. Problem solved.
Was this helpful to you?
Quote

Question owner

Correction! The registry fix works until you close Firefox, when it updates the registry and puts back the deleted item, thus forcing the pop up again. Once again, Firefox ignores the user settings and does what it wants. As I have no intention of editing the registry each and every time, has anyone any idea how to stop Firefox from changing the registry settings? Or perhaps, a working fix?

Correction! The registry fix works until you close Firefox, when it updates the registry and puts back the deleted item, thus forcing the pop up again. Once again, Firefox ignores the user settings and does what it wants. As I have no intention of editing the registry each and every time, has anyone any idea how to stop Firefox from changing the registry settings? Or perhaps, a working fix?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17860 solutions 161609 answers

It is not Firefox that adds these keys to the Windows Registry, but this is done by other software, possibly security software or software added by an IT department.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

It is not Firefox that adds these keys to the Windows Registry, but this is done by other software, possibly security software or software added by an IT department. Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *https://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.