Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't block updates

  • 5 replies
  • 1 has this problem
  • 11 views
  • Last reply by TanyaC

more options

Running v68.4.1 esr. Have set app.update.auto to false (interesting this pref shows twice in about:config). Have removed the update URL Firefox is still trying to update. Many updates break something, so I want to manage the 10 PCs on Firefox on my schedule. I test all updates and resolve any issues before I roll out updates - the whole point of an ESR release. What am I missing?

Now that an update has been detected, once I block update, how do I get rid of the notification? If I back up my profile folder, uninstall and reinstall Firefox, then copy back my profile is it simply going to put it back to the state it's in now... wanting to update?

Chosen solution

Preferences related to updates, like app.update.auto, have long since been removed from Firefox. Although those preferences can still be set, they no longer do anything.

The correct procedure for blocking Firefox updates is by using the DisableAppUpdate policy in either a policies.json file or Windows Group Policy.

Hope this helps.

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

Preferences related to updates, like app.update.auto, have long since been removed from Firefox. Although those preferences can still be set, they no longer do anything.

The correct procedure for blocking Firefox updates is by using the DisableAppUpdate policy in either a policies.json file or Windows Group Policy.

Hope this helps.

more options

This did not work;

c:\Program Files\Mozilla Firefox\distribution\policies.json

{

"policies": {
  "DisableAppUpdate": true
}

}

Firefox still showed a notification that an update was available.

So I've added the group policy templates and will report back.

more options

If you still wish to try and get the policies.json file working, I'd recommend going into the about:policies page in Firefox and see if the DisableAppUpdate policies is set as an active policy.

If not, Firefox is likely posting an error in the Browser Console when it starts up. The Browser Console can be viewed by pressing Ctrl + Shift + J on your keyboard.

However, using the Windows GPOs is a little easy to implement, if you have the option.

more options

Did you make sure that policies.json doesn't have a hidden .txt file extension (i.e. is a JSON file and not a Text document) ?

more options

Wesley Branton said

However, using the Windows GPOs is a little easy to implement, if you have the option.

Indeed it is. And it works perfectly.

cor-el said

Did you make sure that policies.json doesn't have a hidden .txt file extension (i.e. is a JSON file and not a Text document) ?

Yes, the file is correctly named (no .txt extenstion). I don't hide file extension.

I'm happy with the GPO method. It seems to work well. I've tested it for the last two days. No update nags.

Modified by TanyaC