Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does autofill login not work for, in this instance, Here Maps?

  • 9 replies
  • 1 has this problem
  • 28 views
  • Last reply by avalon2

more options

I have added Here Maps (maps.here.com) to the list of saved logins in Privacy and Security, and checked the autofill box. The site is on my Bookmarks Toolbar - but clicking on the link does not log me in automatically. Other sites login OK.

Does anyone have an idea why this particular site is so shy? I put the web address into saved logins via copy and paste from the browser address, so the link should be correct as it was showing the map. (Although you have to click through to get to the sign-in page - which, however, shows the same address, bar an alphanumeric string.) Do any sites have a way of blocking automatic logins? Can I route Firefox directly to the login page, if that is the problem?

Chosen solution

Thanks for your response, FredMcD.

I had already checked the necessary boxes to save logins and allow autofill, and it did seem to work on certain web pages.

I note your warning that some sites do not allow autofill, although I think my problem was in not understanding quite how autofill works - I realise I still have to 'sign in' to sites, but now Firefox gives me the password prompt to click on. Silly me!

Thanks again Fred.

Read this answer in context 👍 0

All Replies (9)

more options

When you access the website, how do you get to the login page?


Type about:preferences#security<enter> in the address bar. Look under Logins,

Note: For Firefox v56+ its; about:preferences#privacy Look under Forms & Passwords +++++++++++++++++++++++++++++++ Turn on Remember Logins. To check the passwords you have listed, press Saved Logins.

Press the Exceptions button and see what's inside.


Warning: There are some web pages that do not allow browsers to record or fill in the log-in information.

more options

Chosen Solution

Thanks for your response, FredMcD.

I had already checked the necessary boxes to save logins and allow autofill, and it did seem to work on certain web pages.

I note your warning that some sites do not allow autofill, although I think my problem was in not understanding quite how autofill works - I realise I still have to 'sign in' to sites, but now Firefox gives me the password prompt to click on. Silly me!

Thanks again Fred.

more options

Note that you only need to enter the domain with the proper protocol (https or http) and not extras like path and hash. For this forum it would be:

Can you use "Fill Login" and "Fill password" in the right-click context menu to fill this data ?

more options

Not sure about the right-click method - what would be the context in which I could use it? That is, at which stage of calling up the web address would this context menu be available?

I probably haven't understood your suggestion; could you explain?

Thanks.

more options

That is about right-clicking in the input fields for username (Fill Login) and password (Fill Password).

more options

Thanks for that cor-el.

In my case (Firefox v72.0) right clicking the input fields brings up a drop-down menu with various options including 'Fill login'. Click on that and another box appears saying 'No Login Suggestions', even though the site address has been added to 'Saved Logins'.

But no matter - a left click on the the input fields does bring up the login password etc. Click again and it's entered. That's nice and simple!

Maybe it's different for your version?

more options

My logins no longer autofill for any website. I think one of my recent updates turned Lockwise back on. So, as previously suggested by jscher2000 [https://support.mozilla.org/en-US/que.../1272634#answer-1267640|jscher2000], I erased the string text in signon.management.overrideURI. The old Password Manager's style of presentation is back (i.e. no more Lockwise). But even after a restart Firefox (72.0.1) still won't autofill. I'm still getting the "from this website" and a dropdown menu for the "login name/account" stuff but still no password autofill. No clicking(s) suggest a password. Security Prefs are right, there are zero listings in Exceptions and my login data is still saved. Jsher2000 said this work-around would not last forever, he was right. Any ideas?

more options

There is a checkbox for auto-fill in "Options/Preferences -> Privacy & Security -> Logins and Passwords".

more options

cor-el said

There is a checkbox for auto-fill in "Options/Preferences -> Privacy & Security -> Logins and Passwords".

Cor-el, thanks for answering. It appears to me that there is no Logins/Passwords tab, pane or checkbox there or even super well hidden in the side bar, like under "Location Services". I suspect it must have disappeared in the macOS Mojave 10.14.

BUT, by all means I know I may be missing it. If you have Mojave to check with and can direct me to the right spot I would be so eternally grateful.

Under "Security and Privacy" -> "General", there is a "disable automatic login" checkbox but that one is for getting general computer access upon a user login (like after Shutdowns, Restarts, power failures, etc). I hope I do have some mental block for seeing it, but otherwise it's not in there. Again, I'd be very grateful, if you know click-by-click where it is, if you could educate me.

Thank you very much for your reply!