X
Tap here to go to the mobile version of the site.

Support Forum

Zillow.com goes to blank screen when I click on a listing. Works fine one my edge brouser.

Posted

After the search for property comes up with the available homes for sale, the pictures and description shows for all the homes in the search. If I click on a property in the search it brings the property up for a few seconds and then goes to a square blank screen. Edge and chrome work fine but I would rather use Firefox. Hope this helps out.

After the search for property comes up with the available homes for sale, the pictures and description shows for all the homes in the search. If I click on a property in the search it brings the property up for a few seconds and then goes to a square blank screen. Edge and chrome work fine but I would rather use Firefox. Hope this helps out.
Quote

Additional System Details

Installed Plug-ins

Duck Duck go

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Hi larrywsund, you said --

If I click on a property in the search it brings the property up for a few seconds and then goes to a square blank screen.

Is that an overlay which appears in front of the search results/map, in the same tab, or is it a separate tab/window?

If an overlay goes blank in the same tab, possibly an extension which cleanses ads out of pages is a bit confused about the content and thinks it's an ad. Do any of your add-ons modify page content?

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Otherwise, here are some standard suggestions:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi larrywsund, you said -- <blockquote> If I click on a property in the search it brings the property up for a few seconds and then goes to a square blank screen. </blockquote> Is that an overlay which appears in front of the search results/map, in the same tab, or is it a separate tab/window? If an overlay goes blank in the same tab, possibly an extension which cleanses ads out of pages is a bit confused about the content and thinks it's an ad. Do any of your add-ons modify page content? Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. ''Otherwise, here are some standard suggestions:'' '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote

Question owner

No help clearing the cache and cookies. I went to safe mode and the Zillow site worked as it should. I checked the site again after rebooting firefox and the overlay went blank again. Thank you for the detailed instructions they are much appreciated. Hope we can come up with a fix.

No help clearing the cache and cookies. I went to safe mode and the Zillow site worked as it should. I checked the site again after rebooting firefox and the overlay went blank again. Thank you for the detailed instructions they are much appreciated. Hope we can come up with a fix.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Helpful Reply

Could it be your DuckDuckGo extension? Does it have a toolbar button that allows turning it off for Zillow?

Could it be your DuckDuckGo extension? Does it have a toolbar button that allows turning it off for Zillow?
Was this helpful to you? 1
Quote

Question owner

I disabled duck duck go and it allowed the overlay to show the pictures. I'm not sure how to go into the add on but that solves the problem. Thanks

I disabled duck duck go and it allowed the overlay to show the pictures. I'm not sure how to go into the add on but that solves the problem. Thanks
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.