X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird causing video problem

Posted

I am running OS-X High Sierra on a iMac (21.5-inch, Mid 2011) 2.5 GHz Intel Core i5 with 12 GB of memory. If and only if I start Thunderbird 68.3.1 I get the blinking squares as seen in https://youtu.be/8zcvvXsp61M These blinking squares frequently cover the entire screen and occasionally lock up the computer. If I never start Thunderbird I never have this problem. When I do start Thunderbird the problem starts within seconds. Within the past couple of months, Firefox changed their rendering approach:

https://mozillagfx.wordpress.com/2019/10/22/dramatically-reduced-power-usage-in-firefox-70-on-macos-with-core-animation/

I wonder if Thunderbird is similarly impacted, and whether Firefox's changes would affect this... I like Thunderbird but I can't live with this.

I am running OS-X High Sierra on a iMac (21.5-inch, Mid 2011) 2.5 GHz Intel Core i5 with 12 GB of memory. If and only if I start Thunderbird 68.3.1 I get the blinking squares as seen in https://youtu.be/8zcvvXsp61M These blinking squares frequently cover the entire screen and occasionally lock up the computer. If I never start Thunderbird I never have this problem. When I do start Thunderbird the problem starts within seconds. Within the past couple of months, Firefox changed their rendering approach: https://mozillagfx.wordpress.com/2019/10/22/dramatically-reduced-power-usage-in-firefox-70-on-macos-with-core-animation/ I wonder if Thunderbird is similarly impacted, and whether Firefox's changes would affect this... I like Thunderbird but I can't live with this.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3391 solutions 23491 answers

Change the setting in Options/Preferences >Advances> general to use hardware acceleration. That often impacts those sorts of issues. It is not so much as on or off is correct, as the correct setting appear to be video driver dependent.

If the changes you mention are the cause, they would have appeared in Thunderbird 68.2 as that would be the Firefox ESR version it appeared in.

Change the setting in Options/Preferences >Advances> general to use hardware acceleration. That often impacts those sorts of issues. It is not so much as on or off is correct, as the correct setting appear to be video driver dependent. If the changes you mention are the cause, they would have appeared in Thunderbird 68.2 as that would be the Firefox ESR version it appeared in.
Was this helpful to you? 0
Quote

Question owner

I have had this problem for a while. It just took me some time to be sure it was not Hardware caused. I use OS-X Options/Preferences >Advances is not a path name that I have.

I have had this problem for a while. It just took me some time to be sure it was not Hardware caused. I use OS-X Options/Preferences >Advances is not a path name that I have.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3391 solutions 23491 answers

Not a path... a menu. I really don;t recall where macos puts preference/options, but I think it is the Thunderbird menu.

Not a path... a menu. I really don;t recall where macos puts preference/options, but I think it is the Thunderbird menu.
Was this helpful to you? 0
Quote

Question owner

I found the option to "Use Hardware Acceleration when available". It did not help. I still have the problem. This has been on going for a couple of months or more. I spent some time making sure it was not a hardware problem. I hate taking the iMac apart. It took me a while to prove to myself that it only happens when I start Thunderbird on my iMac with High Sierra. I have a Mac-mini (late 2009) with El Capitan and it does not have this problem. Both the iMac and the mac-mini have the same version of Thunderbird. It only happens on the iMac and it happens every time I start Thunderbird. The iMac was the one I used for email until I discovered it did not happen on the mac-mini.

I found the option to "Use Hardware Acceleration when available". It did not help. I still have the problem. This has been on going for a couple of months or more. I spent some time making sure it was not a hardware problem. I hate taking the iMac apart. It took me a while to prove to myself that it only happens when I start Thunderbird on my iMac with High Sierra. I have a Mac-mini (late 2009) with El Capitan and it does not have this problem. Both the iMac and the mac-mini have the same version of Thunderbird. It only happens on the iMac and it happens every time I start Thunderbird. The iMac was the one I used for email until I discovered it did not happen on the mac-mini.
Was this helpful to you?
Quote

Question owner

Several days with no blinking squares. I started Thunderbird and they were back within minutes. If I open Firefox or Chrome and drag the window around it will sometimes get rid of the blinking squares. This is making me nuts.

Several days with no blinking squares. I started Thunderbird and they were back within minutes. If I open Firefox or Chrome and drag the window around it will sometimes get rid of the blinking squares. This is making me nuts.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1898 solutions 9485 answers

Helpful Reply

Start the Mac in OS X safe mode and see if the problem remains when you run TB. That would at least indicate issues with the video device driver.

Start the Mac in OS X safe mode and see if the problem remains when you run TB. That would at least indicate issues with the video device driver.
Was this helpful to you? 1
Quote

Question owner

I have been up and running in "Safe mode" for a couple of hours with Thunderbird up the whole time. I have sent and received multiple emails and the problem has not reoccurred. Normally by this time I would have blinking squares.

I have been up and running in "Safe mode" for a couple of hours with Thunderbird up the whole time. I have sent and received multiple emails and the problem has not reoccurred. Normally by this time I would have blinking squares.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1898 solutions 9485 answers

Since safe mode runs with a basic set of device drivers, it looks like drivers are the thing to look at in this case, but on Windows, at least, safe mode also bypasses startup apps that might be causing the problem. I'm not too familiar with OS X safe mode, but startup items are another thing to consider.

Since safe mode runs with a basic set of device drivers, it looks like drivers are the thing to look at in this case, but on Windows, at least, safe mode also bypasses startup apps that might be causing the problem. I'm not too familiar with [https://support.apple.com/en-ca/HT201262 OS X safe mode], but startup items are another thing to consider.
Was this helpful to you?
Quote

Question owner

I ran Apple hardware diagnostics extended test for 3 straight hours yesterday and it reported no errors. Everything is pointing to a driver problem. If that is the case it seems that others should be having this or a similar problem. But I cannot find any evidence of that. And starting Thunderbird is a sure way to set this off. Thunderbird updated itself yesterday and that makes the third version of Thunderbird and the problem still exists.

I ran Apple hardware diagnostics extended test for 3 straight hours yesterday and it reported no errors. Everything is pointing to a driver problem. If that is the case it seems that others should be having this or a similar problem. But I cannot find any evidence of that. And starting Thunderbird is a sure way to set this off. Thunderbird updated itself yesterday and that makes the third version of Thunderbird and the problem still exists.
Was this helpful to you?
Quote

Helpful Reply

I figured out how to stop the blinking squares. Quartz Debug. I had 100+ blinking squares on the screen. I started Quartz Debug and told it to "Disable 2D Acceleration". The second I did that all the blinking squares disappeared and have not come back. I believe Firefox changed its rendering code to use modern APIs last fall; I'm not sure that Thunderbird followed suit, so it could be a software flaw from the old graphics APIs...

I figured out how to stop the blinking squares. Quartz Debug. I had 100+ blinking squares on the screen. I started Quartz Debug and told it to "Disable 2D Acceleration". The second I did that all the blinking squares disappeared and have not come back. I believe Firefox changed its rendering code to use modern APIs last fall; I'm not sure that Thunderbird followed suit, so it could be a software flaw from the old graphics APIs...
Was this helpful to you? 2
Quote
Matt
  • Top 10 Contributor
  • Moderator
3391 solutions 23491 answers

While I do not understand a lot of the graphics stuff. Thunderbird uses the same graphics as the "equivalent" Firefox. (Thunderbird 68.4- Firefox 72. Thunderbird point releases align with Firefox releases.) Because the two programs are built on the Mozilla platform, things like certificates and graphics are shared code. It is also why oAuth2.0 works in Thunderbird, because it has a browser context to display the authorization windows in.

My understanding is that 2d acceleration was disabled when the use hardware acceleration was turned off, or safe mode was invoked.

Have a look in the troubleshooting information on the help menu, you will see fairly detailed graphics information. With my 5 year old driver and 8 year old computer, I do not see much of any thing in the way of advanced graphics.

While I do not understand a lot of the graphics stuff. Thunderbird uses the same graphics as the "equivalent" Firefox. (Thunderbird 68.4- Firefox 72. Thunderbird point releases align with Firefox releases.) Because the two programs are built on the Mozilla platform, things like certificates and graphics are shared code. It is also why oAuth2.0 works in Thunderbird, because it has a browser context to display the authorization windows in. My understanding is that 2d acceleration was disabled when the use hardware acceleration was turned off, or safe mode was invoked. Have a look in the troubleshooting information on the help menu, you will see fairly detailed graphics information. With my 5 year old driver and 8 year old computer, I do not see much of any thing in the way of advanced graphics.
Was this helpful to you? 1
Quote

Question owner

I previously found the Thunderbird option "Use Hardware Acceleration when available" on or off it did not seem to make any difference. I'm not sure what I lost by using Quartz Debug to "Disable 2D Acceleration" but it worked as far as getting rid of the hundreds to thousands of blinking squares. I am still trying to find out what I lost by doing this. At the moment I am happy to be able to use my iMac for email instead of reverting to a mac-mini. The mac-mini has the same version of Thunderbird just running on an older version of OS-X. The mac-mini does not have any problems. Thank You for the reply. If you find any other information about this please let me know.

I previously found the Thunderbird option "Use Hardware Acceleration when available" on or off it did not seem to make any difference. I'm not sure what I lost by using Quartz Debug to "Disable 2D Acceleration" but it worked as far as getting rid of the hundreds to thousands of blinking squares. I am still trying to find out what I lost by doing this. At the moment I am happy to be able to use my iMac for email instead of reverting to a mac-mini. The mac-mini has the same version of Thunderbird just running on an older version of OS-X. The mac-mini does not have any problems. Thank You for the reply. If you find any other information about this please let me know.
Was this helpful to you?
Quote

Question owner

Using Quartz Debug to Disable 2D Acceleration gets rid of the blinking squares, in fact I can have hundreds of them on the screen and when I check Disable 2D Acceleration they all disappear instantly. The down side is doing things like scrolling down a webpage or scrolling down google maps is painfully slow. I'm still trying to pinpoint the root cause.

Using Quartz Debug to Disable 2D Acceleration gets rid of the blinking squares, in fact I can have hundreds of them on the screen and when I check Disable 2D Acceleration they all disappear instantly. The down side is doing things like scrolling down a webpage or scrolling down google maps is painfully slow. I'm still trying to pinpoint the root cause.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.