Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hello I want to enter the site of my surveillance cameras in the company through the latest version of your browser

  • 5 replies
  • 1 has this problem
  • 6 views
  • Last reply by alftoh

more options

Hello I want to enter the site of my surveillance cameras in the company through the latest version of your browser and I cannot try in all ways and fail

The problem is a message (download Pelign) and indeed whatever you download it always comes the same message

Your old version 28 must be downloaded for this message to not appear

Attached screenshots

All Replies (5)

more options

What plugins are required?

This may be your problem,

All Firefox v52+ Releases disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link}

more options

Not my problem on my own

I tried on more than one device in more than one Windows

I want a solution to open the site link. What should I do ??

Is there any specific software that I download to make sure

more options

The entry was tried without any additions

Restart With Addone Disabled

And the same problem

more options

Can't you contact support for that Alhua / Dahua camera interface? http://us.dahuasecurity.com/

I found this: https://dahuawiki.com/Troubleshoot/Browser_Issues

Apparently the firmware version of the camera might be part of the issue for you. Dahua IP Camera with Firmware Version 2.8 or Higher is supposed to be compatible with Firefox & Chrome, per this page: http://dahuawiki.com/Remote_Access/Plugin_Free Problem is that page has no date; could be an old page being that it's not encrypted.

Or try this WebExtension for Firefox Quantum 57-plus: https://addons.mozilla.org/en-US/firefox/addon/myipcam-for-ip-cameras/

more options

Contact was made with Dahua Company

The problem is yours, and what proves that is that version 28 is operating normally

Please send solutions to try