Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TB working well for years. - Last week -can't send on TB, but can receive.Can send & recieve on Yahoo web.Yahoo says settings right. Msg asks click security exc

  • 14 replies
  • 2 have this problem
  • 39 views
  • Last reply by milesrf

more options

Thunderbird working well for years. Last week I can't send by I can receive on TB. Can send and receive on Yahoo web on line. Called Yahoo - they confirmed my settings for outgoing are correct. Error message says Sending of the message failed. The message could not be sent using Outgoing server (SMTP) smtp.att.yahoo.com for an unknown reason. Please verify that your Outgoing server (SMTP) settings are correct and try again. ==

Also a box with info below appears

Add Security Exception

You are about to override how Thunderbird identifies this site

Legitimate banks, stores and other public sites will not ask you to do this

Server smtp.att.yahoo.com:465

Certificate status

This site attempts to identify itself with invalid information

Wrong site

This certificate belongs to a different site, which could mean that someone is trying to impersonate this site

X permanently store this exception

confirm security exception box or Cancel Box


I can view certificate - it should be OK - it is supposed to be good from 10/3/19 to 4/1/20. I can send numbers if you want.

The Yahoo guy on the phone said I should check with you about the certificate

Any help is appreciated.

Thank you

All Replies (14)

more options

Please post a screenshot of the exception prompt as well as one of the certificate viewer window with the issuer information visible. https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem

more options

Both screen shot of exception notification and certificate upload below - I hope

Thank you

more options

You're trying to access smtp.att.yahoo.com. But the cert has been issued to smtp.mail.yahoo.com. There's a mismatch, hence you do get the exception prompt.

ATT/Yahoo should be able to tell whether your outgoing server setting is correct or not. If it is correct, they screwed up their cert configuration.

In any case, you should check with them.

more options

Do you have a security/AV app scanning email or secure (SSL) connections like the one for the smtp server on port 465? If so, both options should be disabled, as they often produce the kinds of errors you see.

more options

Thank you christ1 - I did not notice mismatch. I will call Yahoo back. Thank you again

more options

Chosen Solution

more options

Well I called Yahoo - they confirmed it is smtp.mail.yahoo.com. and not smtp.att.yahoo.com - made the change - and thankfully it is now working. Yeah- Not sure why the att one had been working before - but I am just glad now to have email back to normal. Thank you for being on line on a cold and dank day

more options

Blugoose said

Well I called Yahoo - they confirmed it is smtp.mail.yahoo.com. and not smtp.att.yahoo.com - made the change - and thankfully it is now working. Yeah- Not sure why the att one had been working before

It worked because yahoo are basically so incompetent with their email system that they installed the wrong certificate on the server. It is not a security issue for you, it is poor management by your ISP for continuing a contract with a provider that apparently can not manage to install the correct certificates on the correct machines.

more options

apparently the internet service supplier changed the stmp (simple transportation management protocol) on us without telling us to adjust our settings. I have the book from at&t with the handwriting denoting the last change.

more options

The ISP (ATT) actually did tell us to change the SMTP server settings, but in a way that did not call attention to just what to change (an unexpected portion of the server name).

more options

what is worse is that i contacted them by internet, and tried to get some help, but it was a big hassle to deal with, and there was no way to otherwise contact them except a phone call, which can also be a hassle.

more options

Hello, I have a similar problem with an automatic pop up on my email to Add Security Exception etc.

Having read all the suggestions and comments, I am still not sure what I should do about it. Would someone suggest I contact my ISP and ask them about the certificate?

Thank you in advance, if you can help.

Regards, Chris

more options

chris233 said

Would someone suggest I contact my ISP and ask them about the certificate?

No I would suggest you view the certificate details and see who issues it. Not much point contacting your provider if it is issued by your choice of anti virus programs.

more options

One of the details of the certificate to check is its expiration date. Starting on that date, you'll need to replace the certificate with a new one.

Also note that most security certificates show what company issued that company issued that certificate. If this happens, you'll also need to check the security certificate of the company that issued that certificate. And so on up the ladder.

A rather unlikely possibility is that you have the date on your computer set wrong, and therefore it gets wrong results if it checks what certificates are expired.

Another problem I've seen is that the certificate file contains more than one certificate for the same site, and the first one it encounters is expired. Linux can handle this, Windows cannot.

Some ISPs have arranged to a different company to handle email for them. For example, my ISP uses Yahoo. If your ISP does this, find out which company does the email and check the security certificate chain for them also.

Which type of email protocol are you using? The one that uses SMTP for one direction can fail in one direction but not the other if there you are using a different ISP than usual. Switching to a different email protocol, such as IMAP, often works in this case.

Modified by milesrf