X
Tap here to go to the mobile version of the site.

Support Forum

outgoing gmail uses my gbis email address

Posted

I have several gmail addresses that I just got back from being locked out of because of little use. When I get an incoming to these gmail's, and I reply, the reply address is my non-gmail address. I have to click the box and change it to the gmail address before sending. These are on the imap, the ones that work right are pop. What am I missing here? When I first got these addresses, TB set them up, but I can't figure out how to get the right "from" in these emails.

I have several gmail addresses that I just got back from being locked out of because of little use. When I get an incoming to these gmail's, and I reply, the reply address is my non-gmail address. I have to click the box and change it to the gmail address before sending. These are on the imap, the ones that work right are pop. What am I missing here? When I first got these addresses, TB set them up, but I can't figure out how to get the right "from" in these emails.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

In Tools/Account Settings, select an account in the left pane, then check Outgoing Server (SMTP) in the lower right pane. Each account should be sending on an smtp server with the same User Name and password as the account in the left pane, not on a single Default smtp. It looks like all your gmail accounts are sending through the non-gmail account.

Create as many smtp servers, e.g. gmail1, gmail2... as necessary, if they aren't already defined, in Outgoing Server (SMTP) at the bottom of the left pane of Account Settings.

In Tools/Account Settings, select an account in the left pane, then check Outgoing Server (SMTP) in the lower right pane. Each account should be sending on an smtp server with the same User Name and password as the account in the left pane, not on a single Default smtp. It looks like all your gmail accounts are sending through the non-gmail account. Create as many smtp servers, e.g. gmail1, gmail2... as necessary, if they aren't already defined, in Outgoing Server (SMTP) at the bottom of the left pane of Account Settings.
Was this helpful to you?
Quote

Question owner

sfhowes said

In Tools/Account Settings, select an account in the left pane, then check Outgoing Server (SMTP) in the lower right pane. Each account should be sending on an smtp server with the same User Name and password as the account in the left pane, not on a single Default smtp. It looks like all your gmail accounts are sending through the non-gmail account. Create as many smtp servers, e.g. gmail1, gmail2... as necessary, if they aren't already defined, in Outgoing Server (SMTP) at the bottom of the left pane of Account Settings.

This is what I have. All the ones with this issue are the same. They are also on the same ports, but the ones that are pop, are different ports.

''sfhowes [[#answer-1273162|said]]'' <blockquote> In Tools/Account Settings, select an account in the left pane, then check Outgoing Server (SMTP) in the lower right pane. Each account should be sending on an smtp server with the same User Name and password as the account in the left pane, not on a single Default smtp. It looks like all your gmail accounts are sending through the non-gmail account. Create as many smtp servers, e.g. gmail1, gmail2... as necessary, if they aren't already defined, in Outgoing Server (SMTP) at the bottom of the left pane of Account Settings. </blockquote> This is what I have. All the ones with this issue are the same. They are also on the same ports, but the ones that are pop, are different ports.

Modified by Nightowl

Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

Do all your gmail accounts send through the same server named Google Mail as in your picture? Of course, all gmail accounts send through the same server, smtp.gmail.com, but should send on an smtp.gmail.com with matching User Name and password. Also, if your IMAP accounts use OAuth2 authentication, so should the associated smtp server. OAuth2 is not currently supported for gmail POP accounts in TB.

Do all your gmail accounts send through the same server named Google Mail as in your picture? Of course, all gmail accounts send through the same server, smtp.gmail.com, but should send on an smtp.gmail.com with matching User Name and password. Also, if your IMAP accounts use OAuth2 authentication, so should the associated smtp server. OAuth2 is not currently supported for gmail POP accounts in TB.
Was this helpful to you?
Quote

Question owner

sfhowes said

Do all your gmail accounts send through the same server named Google Mail as in your picture? Of course, all gmail accounts send through the same server, smtp.gmail.com, but should send on an smtp.gmail.com with matching User Name and password. Also, if your IMAP accounts use OAuth2 authentication, so should the associated smtp server. OAuth2 is not currently supported for gmail POP accounts in TB.

Here are 2 more.

''sfhowes [[#answer-1273316|said]]'' <blockquote> Do all your gmail accounts send through the same server named Google Mail as in your picture? Of course, all gmail accounts send through the same server, smtp.gmail.com, but should send on an smtp.gmail.com with matching User Name and password. Also, if your IMAP accounts use OAuth2 authentication, so should the associated smtp server. OAuth2 is not currently supported for gmail POP accounts in TB. </blockquote> Here are 2 more.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

Please post a picture of Outgoing Server (SMTP) at the bottom of the left pane of Account Settings.

Please post a picture of Outgoing Server (SMTP) at the bottom of the left pane of Account Settings.
Was this helpful to you?
Quote

Question owner

sfhowes said

Please post a picture of Outgoing Server (SMTP) at the bottom of the left pane of Account Settings.

The only thing I find for what you ask is the first picture I posted above.

''sfhowes [[#answer-1273385|said]]'' <blockquote> Please post a picture of Outgoing Server (SMTP) at the bottom of the left pane of Account Settings. </blockquote> The only thing I find for what you ask is the first picture I posted above.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

See the attached picture for an example of what I'm asking for.

See the attached picture for an example of what I'm asking for.
Was this helpful to you?
Quote

Question owner

sfhowes said

See the attached picture for an example of what I'm asking for.

Sorry about that.

''sfhowes [[#answer-1273396|said]]'' <blockquote> See the attached picture for an example of what I'm asking for. </blockquote> Sorry about that.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

If all the servers named 'Google Mail' have unique User Name entries, I highly recommend you rename them Google Mail 1, Google Mail 2, Google Mail 3.... so that when you select the smtp server, by selecting the account in the left pane and then Outgoing Server (SMTP) in the right pane, each account will send on the correct smtp.

If all the servers named 'Google Mail' have unique User Name entries, I highly recommend you rename them Google Mail 1, Google Mail 2, Google Mail 3.... so that when you select the smtp server, by selecting the account in the left pane and then Outgoing Server (SMTP) in the right pane, each account will send on the correct smtp.
Was this helpful to you?
Quote

Question owner

sfhowes said

If all the servers named 'Google Mail' have unique User Name entries, I highly recommend you rename them Google Mail 1, Google Mail 2, Google Mail 3.... so that when you select the smtp server, by selecting the account in the left pane and then Outgoing Server (SMTP) in the right pane, each account will send on the correct smtp.

So you're saying to go to server settings for each one, and rename the email address that's in the username box to gmail1, 2, etc?

''sfhowes [[#answer-1273404|said]]'' <blockquote> If all the servers named 'Google Mail' have unique User Name entries, I highly recommend you rename them Google Mail 1, Google Mail 2, Google Mail 3.... so that when you select the smtp server, by selecting the account in the left pane and then Outgoing Server (SMTP) in the right pane, each account will send on the correct smtp. </blockquote> So you're saying to go to server settings for each one, and rename the email address that's in the username box to gmail1, 2, etc?
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

No, change the Description entry so that it isn't Google Mail for every gmail server. Make it something like 'GM <part before the @>'. That will make it a lot easier to match the accounts with the correct smtp.

No, change the Description entry so that it isn't Google Mail for every gmail server. Make it something like 'GM <part before the @>'. That will make it a lot easier to match the accounts with the correct smtp.
Was this helpful to you?
Quote

Question owner

sfhowes said

No, change the Description entry so that it isn't Google Mail for every gmail server. Make it something like 'GM <part before the @>'. That will make it a lot easier to match the accounts with the correct smtp.

I changed 1 that used to show "google mail" in that picture above, then went to that email and it still replies as my default. I'm not grasping this.

''sfhowes [[#answer-1273408|said]]'' <blockquote> No, change the Description entry so that it isn't Google Mail for every gmail server. Make it something like 'GM <part before the @>'. That will make it a lot easier to match the accounts with the correct smtp. </blockquote> I changed 1 that used to show "google mail" in that picture above, then went to that email and it still replies as my default. I'm not grasping this.
Was this helpful to you?
Quote

Question owner

ok, I was using just 1 or 2 of those emails during this conversation. I went through all of them and changed the names. The last one in the list shown above in my last picture (not the att, the google one) does do the reply the right way, so I went through all them again and they are set up exactly the way the one at the bottom is, yet they use my default non-gmail as the sender when trying to reply with them. I'm just confused as heck because if they are set up the same way, with the same values, port, to, from, smtp server, imap, etc...then why 1 on not the others? Could this be because of them being formerly locked up? I was never locked out of the ones that work right, including the imap one, so is it possible it's something on googles side doing this? Maybe it's the way I got those accounts back? I never had any recovery email or phone numbers attached to them, and it was quite a time consuming ordeal to get them unlocked without googles help.

ok, I was using just 1 or 2 of those emails during this conversation. I went through all of them and changed the names. The last one in the list shown above in my last picture (not the att, the google one) '''does''' do the reply the right way, so I went through all them again and they are set up exactly the way the one at the bottom is, yet they use my default non-gmail as the sender when trying to reply with them. I'm just confused as heck because if they are set up the same way, with the same values, port, to, from, smtp server, imap, etc...then why 1 on not the others? Could this be because of them being formerly locked up? I was never locked out of the ones that work right, including the imap one, so is it possible it's something on googles side doing this? Maybe it's the way I got those accounts back? I never had any recovery email or phone numbers attached to them, and it was quite a time consuming ordeal to get them unlocked without googles help.

Modified by Nightowl

Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3361 solutions 23290 answers

No you are not grasping this.


Harking back to this

Work your way down that list and change the name of every single entry that says Google mail. That will be 10 or 11 changes. depending on what is under the red on the top entry.

Change the name to something that clearly identifies the account it applies to. The suggestion was

Make it something like 'GM <part before the @>'.

The sole purpose of this making the name used clear is you will have to then go to the account settings for each and every account in the account settings list and check/change the outgoing server SMTP used to the correct one. Having ten entries of the same names makes it impossible for you to manually review if the correct outgoing server is being used without clicking edit to see the user name being used to send mail for that account.

Finally, when you click to send, do your check the from line in the composer? Thunderbird will use the default SMTP server and from most of the time anyway unless you specifically set that when you write the email.

No you are not grasping this. Harking back to this <Img src=https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-12-13-16-42-51-9df14a.png> Work your way down that list and change the name of every single entry that says Google mail. That will be 10 or 11 changes. depending on what is under the red on the top entry. Change the name to something that clearly identifies the account it applies to. The suggestion was <blockquote> Make it something like 'GM <part before the @>'. </blockquote> The sole purpose of this making the name used clear is you will have to then go to the account settings for each and every account in the account settings list and check/change the outgoing server SMTP used to the correct one. Having ten entries of the same names makes it impossible for you to manually review if the correct outgoing server is being used without clicking edit to see the user name being used to send mail for that account. Finally, when you click to send, do your check the from line in the composer? Thunderbird will use the default SMTP server and from most of the time anyway unless you specifically set that when you write the email.
Was this helpful to you?
Quote

Question owner

I did change them all. Still has the same issue. The default under the red is my normal non-gmail address.

To make changing them to be easier to remember, I changed them to the first part of the email address. I even made one of the ones not replying correctly the default, and they still reply the same way, which is with the former default non-gmail address.

As far as going to each account setting and checking, yes, the names I changed them to is there under "edit smtp server"

Like I said, one of them is working like it should.

And yes, on the ones not replying correctly, I have to click the drop down menu and select "from" the one I am replying with. Except for that lone address that works right.

I did change them all. Still has the same issue. The default under the red is my normal non-gmail address. To make changing them to be easier to remember, I changed them to the first part of the email address. I even made one of the ones not replying correctly the default, and they still reply the same way, which is with the former default non-gmail address. As far as going to each account setting and checking, yes, the names I changed them to is there under "edit smtp server" Like I said, one of them is working like it should. And yes, on the ones not replying correctly, I have to click the drop down menu and select "from" the one I am replying with. Except for that lone address that works right.

Modified by Nightowl

Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3361 solutions 23290 answers

experiment time.

Change the default to another account... any one... does the original that worked file still do so? Do the others change?

Are you using the all folders view of folders, or one of the others. The unified view tends to use the default for just about everything, while the "all mail" view will use the account that is selected in the folder pane on the left.

experiment time. Change the default to another account... any one... does the original that worked file still do so? Do the others change? Are you using the all folders view of folders, or one of the others. The unified view tends to use the default for just about everything, while the "all mail" view will use the account that is selected in the folder pane on the left.
Was this helpful to you?
Quote

Question owner

I just changed default to one of the others and everything is the same. As far as folder view, I don't even look at the "all files" folders in gmail. Just the inbox. I do see when I get one email, it shows 3 until I go to that email. 1 in inbox, 1 in all files, and 1 in important. I look at the inbox, and reply from there. After I delete that email, and the sent email, the other 2 folders empty. Wait... you mean when my TB opens, what do I see? I see all my email addresses on the left pane in order when I created them. Sorry, I have been desoldering and soldering a board trying to find a short most the day. My brain is fried.

I just changed default to one of the others and everything is the same. As far as folder view, I don't even look at the "all files" folders in gmail. Just the inbox. I do see when I get one email, it shows 3 until I go to that email. 1 in inbox, 1 in all files, and 1 in important. I look at the inbox, and reply from there. After I delete that email, and the sent email, the other 2 folders empty. Wait... you mean when my TB opens, what do I see? I see all my email addresses on the left pane in order when I created them. Sorry, I have been desoldering and soldering a board trying to find a short most the day. My brain is fried.

Modified by Nightowl

Was this helpful to you?
Quote

Question owner

I think I found the problem. I deleted one of those accounts then added it again. It took TB quite a while to populate the folders in that account. After that was all done, I sent an email to it and another one of those accounts. Both replied the right way. I kept emailing back and forth maybe 6 times each. Every time they worked.

Every night, I dump all cookies and history in FireFox. I did that, then went back to email out of curiosity. Each 1 worked 1 more time before replying the wrong way. So I have to assume that's the problem. Yet I have the gmail/google cookie in permanent because of the last time I was here asking for help. I also have problems between FireFox and my anti-virus. If I clear cookies and history in my anti-virus, it puts back bookmarks I deleted in FireFox. That's why I did this experiment. There's no reason it should be doing this. If I have to keep all cookies and history forever, then it's not worth trying to get things like they should be.

I assume you guys gave up on me, but I'm still working through this. Ahhh, 1 more thing..when I added that 1 account again after deleting it, TB gave me the option to go imap or pop. I chose imap, but when I checked the server setting, it had a different port than the others. Went out then back, and it had the same port as the others?

Oh well, I'll just deal with it.

I think I found the problem. I deleted one of those accounts then added it again. It took TB quite a while to populate the folders in that account. After that was all done, I sent an email to it and another one of those accounts. Both replied the right way. I kept emailing back and forth maybe 6 times each. Every time they worked. Every night, I dump all cookies and history in FireFox. I did that, then went back to email out of curiosity. Each 1 worked 1 more time before replying the wrong way. So I have to assume that's the problem. Yet I have the gmail/google cookie in permanent because of the last time I was here asking for help. I also have problems between FireFox and my anti-virus. If I clear cookies and history in my anti-virus, it puts '''back''' bookmarks I deleted in FireFox. That's why I did this experiment. There's no reason it should be doing this. If I have to keep all cookies and history forever, then it's not worth trying to get things like they should be. I assume you guys gave up on me, but I'm still working through this. Ahhh, 1 more thing..when I added that 1 account again after deleting it, TB gave me the option to go imap or pop. I chose imap, but when I checked the server setting, it had a different port than the others. Went out then back, and it had the same port as the others? Oh well, I'll just deal with it.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1822 solutions 9005 answers

Keep in mind that browser cookies are not relevant to mail accounts in TB, but if you use OAuth2 authentication for gmail IMAP accounts, cookies for *.google.com must be allowed in TB under Tools/Options/Privacy.

For accounts that use SSL/TLS connection security, the incoming IMAP port for imap.gmail.com is 993 and the incoming POP port for pop.gmail.com is 995.

Keep in mind that browser cookies are not relevant to mail accounts in TB, but if you use OAuth2 authentication for gmail IMAP accounts, cookies for *.google.com must be allowed in TB under Tools/Options/Privacy. For accounts that use SSL/TLS connection security, the incoming IMAP port for imap.gmail.com is 993 and the incoming POP port for pop.gmail.com is 995.
Was this helpful to you?
Quote

Question owner

sfhowes said

Keep in mind that browser cookies are not relevant to mail accounts in TB, but if you use OAuth2 authentication for gmail IMAP accounts, cookies for *.google.com must be allowed in TB under Tools/Options/Privacy. For accounts that use SSL/TLS connection security, the incoming IMAP port for imap.gmail.com is 993 and the incoming POP port for pop.gmail.com is 995.

The google.com cookie is what I was talking about. All are 993 with the same (not 993) outgoing port. Oauth2, ssl/tsl, and I changed the names as suggested, but 1 works fine while the other don't.

I know browser cookies are not relevant to mail, but after I dumped them, I lost the 2 gmails that sent with the right "from" address. I mean I sent mail, went directly to dump cookies, then back to send mail again, and not working right. Maybe a coincidence.

''sfhowes [[#answer-1273746|said]]'' <blockquote> Keep in mind that browser cookies are not relevant to mail accounts in TB, but if you use OAuth2 authentication for gmail IMAP accounts, cookies for *.google.com must be allowed in TB under Tools/Options/Privacy. For accounts that use SSL/TLS connection security, the incoming IMAP port for imap.gmail.com is 993 and the incoming POP port for pop.gmail.com is 995. </blockquote> The google.com cookie is what I was talking about. All are 993 with the same (not 993) outgoing port. Oauth2, ssl/tsl, and I changed the names as suggested, but 1 works fine while the other don't. I know browser cookies are not relevant to mail, but after I dumped them, I lost the 2 gmails that sent with the right "from" address. I mean I sent mail, went directly to dump cookies, then back to send mail again, and not working right. Maybe a coincidence.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.