X
Tap here to go to the mobile version of the site.

Support Forum

Since 71 upgrade Spellcheck correction has stopped working. Misspelt words are underlined in wiggly red but right-click doesn't offer options to correct or add

Posted

Running Win10 64.

Also right-click not showing paste option on many input fields, such as this text box. This problem only in FF, works fine in other apps, Windows Explorer, Edge etc.

Running Win10 64. Also right-click not showing paste option on many input fields, such as this text box. This problem only in FF, works fine in other apps, Windows Explorer, Edge etc.

Chosen solution

Restarting again with add-ons enable and > jdkjjdjd < was recognised as rubbish.

" worng " was recognised and a right click offered "wrong" as the suggestion - so we're back in business.

Thanks FredMcD.

Any idea how did this got screwed up?

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

British English Dictionary

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

FredMcD
  • Top 10 Contributor
4308 solutions 60488 answers

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker


Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type: '''layout.spellcheckDefault''' Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes. Also, check the '''spellchecker.dictionary''' entry. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker --------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 160003 answers

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that you need a dictionary and not a language pack that provides string translations for the user interface.

Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected. *open the "Add Dictionaries" link to install a dictionary if you do not have one. The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/ Note that you need a <b>dictionary</b> and not a language pack that provides string translations for the user interface.
Was this helpful to you?
Quote

Question owner

layout.spellcheckDefault was set to 1, now set to 2

en-gb The dictionary was loaded and enable

Restarting in Safe Mode the spell checker doesn't work at all, no squiggley line under gibberish - I assume that's because the dictionary is an add-on.

layout.spellcheckDefault was set to 1, now set to 2 en-gb The dictionary was loaded and enable Restarting in Safe Mode the spell checker doesn't work at all, no squiggley line under gibberish - I assume that's because the dictionary is an add-on.
Was this helpful to you?
Quote

Chosen Solution

Restarting again with add-ons enable and > jdkjjdjd < was recognised as rubbish.

" worng " was recognised and a right click offered "wrong" as the suggestion - so we're back in business.

Thanks FredMcD.

Any idea how did this got screwed up?

Restarting again with add-ons enable and > jdkjjdjd < was recognised as rubbish. " worng " was recognised and a right click offered "wrong" as the suggestion - so we're back in business. Thanks FredMcD. Any idea how did this got screwed up?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4308 solutions 60488 answers

Glad to help. Safe Surfing. It could have been a corrupt file that was overwritten

Glad to help. Safe Surfing. It could have been a corrupt file that was overwritten
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.