X
Tap here to go to the mobile version of the site.

Support Forum

My global search function has stopped working completely.

Posted

I've reinstalled, deleted a file as recommended and turned off and on Indexer. I need that search function badly! Any help would be appreciated!

I've reinstalled, deleted a file as recommended and turned off and on Indexer. I need that search function badly! Any help would be appreciated!
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

More Information

sfhowes
  • Top 10 Contributor
1825 solutions 9030 answers

When you restarted TB after deleting global-messages-db.sqlite, did you allow enough time for the rebuild? It can take several minutes, even for a relatively small message store and a fast computer. Progress can be monitored in Tools/Activity Manager.

When you restarted TB after deleting global-messages-db.sqlite, did you allow enough time for the rebuild? It can take several minutes, even for a relatively small message store and a fast computer. Progress can be monitored in Tools/Activity Manager.
Was this helpful to you?
Quote

Question owner

Hey there, the file I deleted was the global-messages-db.sqlite to restart indexing. I also restarted in Safe mode and turned off all add ons and also reset all menus. Still no dice. Also I have noticed that my 'open in conversations' option in my dropdown menu's is also no 'greyed out' so I can't select it.

I gave it an hour after deleting the global file to allow it time but still, no dice :(

Hey there, the file I deleted was the global-messages-db.sqlite to restart indexing. I also restarted in Safe mode and turned off all add ons and also reset all menus. Still no dice. Also I have noticed that my 'open in conversations' option in my dropdown menu's is also no 'greyed out' so I can't select it. I gave it an hour after deleting the global file to allow it time but still, no dice :(
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1825 solutions 9030 answers

Open Tools/Options/Advanced/General/Config. editor and copy mailnews.database.global.indexer.enabled into the Search, and confirm its value is true. Then, close TB and delete global-messages-db.sqlite (again), restart TB and open Tools/Activity Manager to confirm the database is being rebuilt.

When you say global search has stopped working 'completely', keep in mind there are some default limitations, e.g. some folders such as Trash or Junk are not indexed by default, quoted text is not indexed, encrypted messages not indexed etc.

Note also that 'Open Message in Conversation' requires that global search is enabled and working. So, if we fix the latter, the former should work.

Open Tools/Options/Advanced/General/Config. editor and copy ''mailnews.database.global.indexer.enabled'' into the Search, and confirm its value is true. Then, close TB and delete global-messages-db.sqlite (again), restart TB and open Tools/Activity Manager to confirm the database is being rebuilt. When you say global search has stopped working 'completely', keep in mind there are some default limitations, e.g. some folders such as Trash or Junk are not indexed by default, quoted text is not indexed, encrypted messages not indexed etc. Note also that 'Open Message in Conversation' requires that global search is enabled and working. So, if we fix the latter, the former should work.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.