X
Tap here to go to the mobile version of the site.

Support Forum

I can't use certain shortcuts (particularly Ctrl Alt Shift I to open the Browser Toolbox) when I use an international keyboard!

Posted

Title says everything. It's working on a US layout

Title says everything. It's working on a US layout
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

evhenry
  • Top 25 Contributor
  • Administrator
32 solutions 179 answers

to make sure I'm understanding, when you use a non US keyboard layout, CTRL+ALT+SHIFT+i doesn't work when you press that combination? Does it work if you press it where "i" is "normally"?

What other shortcuts stop working when you switch keyboards?

to make sure I'm understanding, when you use a non US keyboard layout, CTRL+ALT+SHIFT+i doesn't work when you press that combination? Does it work if you press it where "i" is "normally"? What other shortcuts stop working when you switch keyboards?
Was this helpful to you?
Quote

Question owner

Hello,

Sorry for the very late reply! I've been busy.

CTRL + ALT + SHIFT + I will cause an accented i to appear in the small search bar when I press that combination (search bar is not open).

So far this is the only shortcut that I know of that stops working.

Darren

Hello, Sorry for the very late reply! I've been busy. CTRL + ALT + SHIFT + I will cause an accented i to appear in the small search bar when I press that combination (search bar is not open). So far this is the only shortcut that I know of that stops working. Darren
Was this helpful to you?
Quote
evhenry
  • Top 25 Contributor
  • Administrator
32 solutions 179 answers

The shortcut should be control+ shift+ i, I don't think the alt is used in it, try that?

The shortcut should be control+ shift+ i, I don't think the alt is used in it, try that?
Was this helpful to you?
Quote

Question owner

Ctrl + Shift + I is for the default toolbox, I was referring to the developer toolbox which uses the shortcut Ctrl + Shift + Alt + I

Ctrl + Shift + I is for the default toolbox, I was referring to the developer toolbox which uses the shortcut Ctrl + Shift + Alt + I
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
574 solutions 5378 answers

darrentohjc said

Ctrl + Shift + I is for the default toolbox, I was referring to the developer toolbox which uses the shortcut Ctrl + Shift + Alt + I

Hello darrentohjc,

In the header of your original post you are referring to the browser toolbox instead of the developer toolbox ..... (?)

According to this article Ctrl + Shift + Alt + I is used for the browser toolbox.

According to this article you need to press Ctrl + Shift + I to open the developer toolbox, like "evhenry" mentioned.

For wat it's worth : pressing Ctrl + Shift + Alt + I doesn't open the browser toolbox for me either, but gives me the "accented i", just like it does for you ....

I hope someone else will be able to solve this mystery .....

''darrentohjc [[#answer-1274743|said]]'' <blockquote> Ctrl + Shift + I is for the default toolbox, I was referring to the developer toolbox which uses the shortcut Ctrl + Shift + Alt + I </blockquote> Hello darrentohjc, In the header of your original post you are referring to the browser toolbox instead of the developer toolbox ..... (?) According to [https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox this article] Ctrl + Shift + Alt + I is used for the browser toolbox. According to [https://developer.mozilla.org/en-US/docs/Tools/Tools_Toolbox this article] you need to press Ctrl + Shift + I to open the developer toolbox, like "evhenry" mentioned. For wat it's worth : pressing Ctrl + Shift + Alt + I doesn't open the browser toolbox for me either, but gives me the "accented i", just like it does for you .... I hope someone else will be able to solve this mystery .....

Modified by McCoy

Was this helpful to you?
Quote

Question owner

Hello,

I apologise for the confusion regarding the different labels that I have been using.

My main issue is that I want to access the toolbox that is assigned to the keyboard shortcut Ctrl + Shift + Alt + I. I have tested and confirmed that this shortcut is working on a US layout keyboard, but not on the United States - International layout.

Hello, I apologise for the confusion regarding the different labels that I have been using. My main issue is that I want to access the toolbox that is assigned to the keyboard shortcut Ctrl + Shift + Alt + I. I have tested and confirmed that this shortcut is working on a US layout keyboard, but not on the United States - International layout.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
574 solutions 5378 answers

darrentohjc said

I apologise for the confusion regarding the different labels that I have been using.

Absolutely no need to apologize !

My main issue is that I want to access the toolbox that is assigned to the keyboard shortcut Ctrl + Shift + Alt + I. I have tested and confirmed that this shortcut is working on a US layout keyboard, but not on the United States - International layout.

Like I mentioned before : the keyboard shortcut doesn't open the browser console for me either, but gives me the acute accent on the letter "I" (uppercase) instead. Ctrl + Shift + Alt + I puts an acute accent on every vowel (uppercase).

I haven't been able to come up with a solution other than to use a US layout keyboard ..... :(

''darrentohjc [[#answer-1275026|said]]'' <blockquote> I apologise for the confusion regarding the different labels that I have been using. </blockquote> Absolutely no need to apologize ! <blockquote> My main issue is that I want to access the toolbox that is assigned to the keyboard shortcut Ctrl + Shift + Alt + I. I have tested and confirmed that this shortcut is working on a US layout keyboard, but not on the United States - International layout. </blockquote> Like I mentioned before : the keyboard shortcut doesn't open the browser console for me either, but gives me the acute accent on the letter "I" (uppercase) instead. Ctrl + Shift + Alt + I puts an acute accent on every vowel (uppercase). I haven't been able to come up with a solution other than to use a US layout keyboard ..... :(

Modified by McCoy

Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
574 solutions 5378 answers

I am going to forward this thread to a fellow contributor who just might know how to solve this mystery (it might take a few hours before he
sees this, though .... )

I am going to forward this thread to a fellow contributor who just might know how to solve this mystery (it might take a few hours before he <BR>sees this, though .... )
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Hmm, as a U.S. English user, I can only know what I see on the web. I don't see a preference in Firefox to handle the keyboard as being from a specific region (such as U.S. English to avoid this behavior).

Could you use the following page and report back what keys are detected when you press Ctrl+Alt+Shift+i:

https://www.jeffersonscher.com/res/keyvents.html

My U.S. English keyboard shows this:

keydown => event.key: "I" + Ctrl + Alt + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI} keyup => event.key: "I" + Ctrl + Alt + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI}

Hmm, as a U.S. English user, I can only know what I see on the web. I don't see a preference in Firefox to handle the keyboard as being from a specific region (such as U.S. English to avoid this behavior). Could you use the following page and report back what keys are detected when you press Ctrl+Alt+Shift+i: https://www.jeffersonscher.com/res/keyvents.html My U.S. English keyboard shows this: keydown => event.key: "I" + Ctrl + Alt + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI} keyup => event.key: "I" + Ctrl + Alt + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI}
Was this helpful to you?
Quote

Question owner

Hi!

Here's what's being registered: keydown => event.key: "Í" + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI} keypress => event.key: "Í" + Shift{charCode: 205; keyCode: 205; which: 205; code: KeyI}

Hi! Here's what's being registered: keydown => event.key: "Í" + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI} keypress => event.key: "Í" + Shift{charCode: 205; keyCode: 205; which: 205; code: KeyI}
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159962 answers

Did you already try to close and restart Firefox and reboot the computer ?

Note that some key combinations may be interpreted as dead keys (i.e. Ctrl+I could be the same as Tab), so maybe also check the Windows accessibility settings and other settings for this keyboard layout.

Did you already try to close and restart Firefox and reboot the computer ? Note that some key combinations may be interpreted as dead keys (i.e. Ctrl+I could be the same as Tab), so maybe also check the Windows accessibility settings and other settings for this keyboard layout.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

darrentohjc said

Hi! Here's what's being registered:
keydown => event.key: "Í" + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI}
keypress => event.key: "Í" + Shift{charCode: 205; keyCode: 205; which: 205; code: KeyI}

Hmm, it look to me like Windows is modifying Ctrl+Alt+i to a special character before it gets to Firefox, but that's just a guess.

''darrentohjc [[#answer-1275116|said]]'' <blockquote> Hi! Here's what's being registered:<br> keydown => event.key: "Í" + Shift{charCode: 0; keyCode: 73; which: 73; code: KeyI}<br> keypress => event.key: "Í" + Shift{charCode: 205; keyCode: 205; which: 205; code: KeyI} </blockquote> Hmm, it look to me like Windows is modifying Ctrl+Alt+i to a special character before it gets to Firefox, but that's just a guess.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159962 answers

What is the modifier combination that is set to rotate the keyboard layout ?

Does it help if you disable these keyboard shortcuts to rotate the layout and instead assign a special keyboard shortcut to select a layout?

What is the modifier combination that is set to rotate the keyboard layout ? Does it help if you disable these keyboard shortcuts to rotate the layout and instead assign a special keyboard shortcut to select a layout?
Was this helpful to you?
Quote

Question owner

Hi all,

I have managed to circumvent this issue by swapping back to the US layout and using Microsoft Keyboard Layout Creator to implement some of the keys I needed to use in the US International layout.

I would still like to be able to highlight this issue to the devs though, as I do think that not every Firefox user is on the US layout, and they may run into the same issues that I have experienced. Could someone direct me to the proper channels for doing so?

Thank you for all your help.

Hi all, I have managed to circumvent this issue by swapping back to the US layout and using Microsoft Keyboard Layout Creator to implement some of the keys I needed to use in the US International layout. I would still like to be able to highlight this issue to the devs though, as I do think that not every Firefox user is on the US layout, and they may run into the same issues that I have experienced. Could someone direct me to the proper channels for doing so? Thank you for all your help.

Modified by darrentohjc

Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
574 solutions 5378 answers

darrentohjc said

I would still like to be able to highlight this issue to the devs though, as I do think that not every Firefox user is on the US layout, and they may run into the same issues that I have experienced. Could someone direct me to the proper channels for doing so?

You can submit feedback using this link :

https://qsurvey.mozilla.com/s3/FirefoxInput/



May I ask : did Ctrl+Shift+Alt+I (uppercase "i") ever work for you on a
US international keyboard ?

''darrentohjc [[#answer-1275229|said]]'' <blockquote> I would still like to be able to highlight this issue to the devs though, as I do think that not every Firefox user is on the US layout, and they may run into the same issues that I have experienced. Could someone direct me to the proper channels for doing so? </blockquote> You can submit feedback using this link : https://qsurvey.mozilla.com/s3/FirefoxInput/ --------------------<BR> May I ask : did Ctrl+Shift+Alt+I (uppercase "i") ever work for you on a <BR>US ''international'' keyboard ?
Was this helpful to you?
Quote

Question owner

No, it has never worked.

No, it has never worked.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
574 solutions 5378 answers

darrentohjc said

No, it has never worked.

Thank you for letting me know. After going over many pages with information about international keyboards, I don't think this particular shortcut could work on an international keyboard.

''darrentohjc [[#answer-1275252|said]]'' <blockquote> No, it has never worked. </blockquote> Thank you for letting me know. After going over many pages with information about international keyboards, I don't think this particular shortcut could work on an international keyboard.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.