X
Tap here to go to the mobile version of the site.

Support Forum

Help with slow startup time BECAUSE of auto update

Posted

Hi there, recently firefox has become almost unuseable. i believe i have discovered why.

every time we open firefox it always checks for updates, until this is completed it wont load any pages. this process takes about 30 seconds and is aggravating when u are just looking for a quick search.

is there any way you can allow me to disable updates or can you patch it so the update checker doesnt stop us from using the internet.

i have tried literally everything in your support, refreshed, safe mode, reinstalled, firewalls, antivirus, everything.

Hi there, recently firefox has become almost unuseable. i believe i have discovered why. every time we open firefox it always checks for updates, until this is completed it wont load any pages. this process takes about 30 seconds and is aggravating when u are just looking for a quick search. is there any way you can allow me to disable updates or can you patch it so the update checker doesnt stop us from using the internet. i have tried literally everything in your support, refreshed, safe mode, reinstalled, firewalls, antivirus, everything.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23509 answers

hello, what kind of antivirus-software are you using on the affected systems?

hello, what kind of antivirus-software are you using on the affected systems?
Was this helpful to you? 0
Quote

Question owner

AVG free, i uninstalled it and it changes nothing.

if i quickly open options and scroll down to updates it shows checking for updates, no pages will load until that is complete and THEN they will load instantly.

but it checks for updates EVERY time u close mozilla and start it again

AVG free, i uninstalled it and it changes nothing. if i quickly open options and scroll down to updates it shows checking for updates, no pages will load until that is complete and THEN they will load instantly. but it checks for updates EVERY time u close mozilla and start it again
Was this helpful to you?
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5412 solutions 40317 answers

By default Firefox will check for application updates once every 12 hours, not every time Firefox is launched.

By default Firefox will check for application updates once every 12 hours, not every time Firefox is launched.
Was this helpful to you? 0
Quote

Question owner

um sorry but thats not what is happening.

it checks for updates every time mozilla is launched. is there any way to stop this or disable the update feature until needed?

um sorry but thats not what is happening. it checks for updates every time mozilla is launched. is there any way to stop this or disable the update feature until needed?
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23509 answers

Helpful Reply

can you still reproduce this problem, when you test it with firefox developer edition?: https://www.mozilla.org/firefox/developer/

can you still reproduce this problem, when you test it with firefox developer edition?: https://www.mozilla.org/firefox/developer/
Was this helpful to you? 1
Quote

Question owner

philipp said

can you still reproduce this problem, when you test it with firefox developer edition?: https://www.mozilla.org/firefox/developer/

That one seems to work perfectly!

''philipp [[#answer-1266965|said]]'' <blockquote> can you still reproduce this problem, when you test it with firefox developer edition?: https://www.mozilla.org/firefox/developer/ </blockquote> That one seems to work perfectly!
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23509 answers

the problem you were seeing is probably https://bugzilla.mozilla.org/show_bug.cgi?id=1591691 in this case - mozilla will fix this in firefox 71.

the problem you were seeing is probably https://bugzilla.mozilla.org/show_bug.cgi?id=1591691 in this case - mozilla will fix this in firefox 71.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.