Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

install an add-on it says "only with Firefox - get Firefox Now"

more options

When I try to install an add-on it says "only with Firefox - get Firefox Now" and I am doing this from Firefox which I updated to the latest version before trying to install the add-on

Chosen solution

I went into about:config and searched for user agent then removed anonymized by Abelssoft 1397394576 from the string and also changed it from NT 6.2 to NT10.0 as I am using Windows 10. retied to install add-on, all worked like a dream. Thank you for the help

Read this answer in context 👍 0

All Replies (7)

more options

Hi Dave-Fr, it's because you are using some software that modifies your browser identification in a way that the Add-ons site doesn't understand. To this forum, your Firefox identified itself as

Mozilla/5.0 (Windows NT 6.2; rv:70.0.1) Gecko/20100101 Firefox/70.0.1 anonymized by Abelssoft 1397394576

Are you using "GoogleClean" or "GClean" or other Abelssoft software?

more options

I am using AntiBrowserSpy from Abelssoft

more options

See whether they can stop modifying your user agent string with their advertising.

more options

Any addition to the user agent apart from Firefox/70.0.1 makes the Add-ons website fail. You can try to save the extension (right-click and use "Save Link As") and install the extension locally via the about:addons page (click the cogwheel button).

more options

Chosen Solution

I went into about:config and searched for user agent then removed anonymized by Abelssoft 1397394576 from the string and also changed it from NT 6.2 to NT10.0 as I am using Windows 10. retied to install add-on, all worked like a dream. Thank you for the help

more options

I don't have those fields...

"searched for 'user agent' then removed anonymized by Abelssoft 1397394576 from the string and also changed it from NT 6.2 to NT10.0 as I am using Windows 10.

more options

Bangemout® said

I don't have those fields... "searched for 'user agent' then removed anonymized by Abelssoft 1397394576 from the string and also changed it from NT 6.2 to NT10.0 as I am using Windows 10.

Please start your own support thread here: https://support.mozilla.org/en-US/