X
Tap here to go to the mobile version of the site.

Support Forum

What is this Code Ghost and How do I Get Rid of It?

Posted

Gentlepeople: On the proprietary website of my credit union, after their recent 2-factor security upgrade, I now see ghosts of code instructions associated with drop-down menus and fill-in boxes. (Please see attached screen capture.) Have not encountered this on any other website. When I log in to the site on Chrome, I don't see this, just the regular page I am used to. I have turned off AdBlockers. Anything else I could do to get a normal image back so I can see the boxes I want to fill in? I am still on Windows7 for Home (will upgrade this Christmas) using Firefox 70.0.1 (64-bit). Any advice, beyond opting for Chrome? Thank you for your assistance. - LA

Gentlepeople: On the proprietary website of my credit union, after their recent 2-factor security upgrade, I now see ghosts of code instructions associated with drop-down menus and fill-in boxes. (Please see attached screen capture.) Have not encountered this on any other website. When I log in to the site on Chrome, I don't see this, just the regular page I am used to. I have turned off AdBlockers. Anything else I could do to get a normal image back so I can see the boxes I want to fill in? I am still on Windows7 for Home (will upgrade this Christmas) using Firefox 70.0.1 (64-bit). Any advice, beyond opting for Chrome? Thank you for your assistance. - LA
Attached screenshots

Chosen solution

Oh, actually, before doing anything else, could clear your cache? Firefox may be mixed old cached files with the new website files and after a redesign, this could make a mess. See: How to clear the Firefox cache.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Helpful Reply

Hi Lorraine4, it reminds me of other threads where images or font-based icons aren't loading so instead you see the backup text for those images. But you don't see glitches on numerous sites, only this one site?

Here are a couple things to check:

Extensions

Some extensions block webfonts, also known as remote fonts. For example, the popular uBlock Origin and NoScript extensions can do that.

Font Settings

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?


There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

Hi Lorraine4, it reminds me of other threads where images or font-based icons aren't loading so instead you see the backup text for those images. But you don't see glitches on numerous sites, only this one site? Here are a couple things to check: '''''Extensions''''' Some extensions block webfonts, also known as remote fonts. For example, the popular uBlock Origin and NoScript extensions can do that. '''''Font Settings''''' * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, scroll down to the "Fonts & Colors" section and click the "Advanced" button. Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above": <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-04-18-11-09-33-79b658.png" width="450"> Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)? ---- There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''gfx.down''' and pause while the list is filtered (3) If the '''gfx.downloadable_fonts.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true Was it any of those things?
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Chosen Solution

Oh, actually, before doing anything else, could clear your cache? Firefox may be mixed old cached files with the new website files and after a redesign, this could make a mess. See: How to clear the Firefox cache.

Oh, actually, before doing anything else, could clear your cache? Firefox may be mixed old cached files with the new website files and after a redesign, this could make a mess. See: [[How to clear the Firefox cache]].
Was this helpful to you?
Quote

Question owner

Jscher2000 - You are my hero. Not sure if was the cache flush or the font dominance assignment that did it, but problem solved. I am so lucky that there are White Knights roaming the internet wastes, fighting evil and conquering glitches. Merci mille fois, monsieur. - Lorraine

Jscher2000 - You are my hero. Not sure if was the cache flush or the font dominance assignment that did it, but problem solved. I am so lucky that there are White Knights roaming the internet wastes, fighting evil and conquering glitches. Merci mille fois, monsieur. - Lorraine
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.