X
Tap here to go to the mobile version of the site.

Support Forum

Firefox keeps crashing when i try to download files. It has done this with pdf, word, and jpeg.

Posted

question above says it all.

question above says it all.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

Dinushi Dhananjani
  • Top 25 Contributor
4 solutions 203 answers

Click on the 3 horizontal lines in the

top right of your Firefox window.
   Select options.
   Under General, scroll down to
the category Applications.
   Find the file type you want to 

change the action on, then select the

action from a drop down menu on the right.

https://support.mozilla.org/en-US/kb/cant-download-or-save-files

Click on the 3 horizontal lines in the top right of your Firefox window. Select options. Under General, scroll down to the category Applications. Find the file type you want to change the action on, then select the action from a drop down menu on the right. https://support.mozilla.org/en-US/kb/cant-download-or-save-files
Was this helpful to you?
Quote

Question owner

Dinushi Dhananjani said

Click on the 3 horizontal lines in the top right of your Firefox window. Select options. Under General, scroll down to the category Applications. Find the file type you want to change the action on, then select the action from a drop down menu on the right. https://support.mozilla.org/en-US/kb/cant-download-or-save-files

well i changed all actions to "always ask" lets see if it helps. thank you.

''Dinushi Dhananjani [[#answer-1264434|said]]'' <blockquote> Click on the 3 horizontal lines in the top right of your Firefox window. Select options. Under General, scroll down to the category Applications. Find the file type you want to change the action on, then select the action from a drop down menu on the right. https://support.mozilla.org/en-US/kb/cant-download-or-save-files </blockquote> well i changed all actions to "always ask" lets see if it helps. thank you.
Was this helpful to you?
Quote

Question owner

still keeps crashing.

still keeps crashing.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Sorry to hear about the crashes. If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.

Also and/or meanwhile, could you test in Firefox's Safe Mode? That temporarily deactivates extensions, hardware acceleration, and some other advanced features of Firefox that might make it more prone to crashing on some systems.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?

Sorry to hear about the crashes. If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "[[Firefox crashes - asking for support]]" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here. Also and/or meanwhile, could you test in Firefox's Safe Mode? That temporarily deactivates extensions, hardware acceleration, and some other advanced features of Firefox that might make it more prone to crashing on some systems. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any less crashy?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.