X
Tap here to go to the mobile version of the site.

Support Forum

gmail authentication error

Posted

My 6 gmail accounts work fine on gmail.com. Until yesterday, all 6 accounts worked fine in Thunderbird as well. However, now a Google window has started to continually ask me to log in to just one of those accounts. After I enter credentials for that account, another window asks for permission to give Thunderbird access to the account. I click allow.

Then a little window in the lower right of the screen says "Authentication failure while connecting to server imap.gmail.com". The Thunderbird logo and name appear in that window.

After that window goes away, the Google window asking for login credentials appears again.

All 6 accounts have the same settings. For both incoming and outgoing servers, connection security is SSL/TLS and authentication method is OAuth2.

In gmail security settings, Thunderbird has access to this gmail account.

I can't figure out what is different about the gmail account that has this problem. I have seen online that hundreds of people have similar problems but have not found clear information about what the problem is and how to solve it. I posted my question to the Google forum but have not received a reply.

I am baffled and hope someone can help.

My 6 gmail accounts work fine on gmail.com. Until yesterday, all 6 accounts worked fine in Thunderbird as well. However, now a Google window has started to continually ask me to log in to just one of those accounts. After I enter credentials for that account, another window asks for permission to give Thunderbird access to the account. I click allow. Then a little window in the lower right of the screen says "Authentication failure while connecting to server imap.gmail.com". The Thunderbird logo and name appear in that window. After that window goes away, the Google window asking for login credentials appears again. All 6 accounts have the same settings. For both incoming and outgoing servers, connection security is SSL/TLS and authentication method is OAuth2. In gmail security settings, Thunderbird has access to this gmail account. I can't figure out what is different about the gmail account that has this problem. I have seen online that hundreds of people have similar problems but have not found clear information about what the problem is and how to solve it. I posted my question to the Google forum but have not received a reply. I am baffled and hope someone can help.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.70 Safari/537.36

More Information

sfhowes
  • Top 10 Contributor
1826 solutions 9031 answers

Helpful Reply

This should be fixed in TB 68.2.1, or you can apply the workaround: https://support.mozilla.org/en-US/questions/1271783#answer-1262722 TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

Modified by sfhowes

Was this helpful to you? 1
Quote

Question owner

Thank you. I tried both of the recommended solutions but it still was not working properly. Then I uninstalled and reinstalled the account and it worked.

I am not sure why it started to work but it is certainly possible that the recommended solutions were essential.

I had not realized that TB needed to be manually updated. I guess I was expecting a notification of some sort. It was surprising that when I went to File > About, the update started to download without my prompting.

Anyway, thank you so much. You are a great resource for us.

Thank you. I tried both of the recommended solutions but it still was not working properly. Then I uninstalled and reinstalled the account and it worked. I am not sure why it started to work but it is certainly possible that the recommended solutions were essential. I had not realized that TB needed to be manually updated. I guess I was expecting a notification of some sort. It was surprising that when I went to File > About, the update started to download without my prompting. Anyway, thank you so much. You are a great resource for us.
Was this helpful to you?
Quote
Drake Bliss 0 solutions 28 answers

Here is what worked for me:

Go to Tools->Options menu, select "Advanced" icon, select "General" tab, click "Config Editor" button,click "I accept the risk!", search for "general.useragent.compatMode.firefox" if it shows "false" double click to change to "true", enter your credentials one LAST time when it prompts. The repeating issue stopped for me. No idea why this works??

I would like to thank Yew Kay Yan for this process! It was driving me crazy having to enter Google Credentials Over and Over and Over...

Here is what worked for me: Go to Tools->Options menu, select "Advanced" icon, select "General" tab, click "Config Editor" button,click "I accept the risk!", search for "general.useragent.compatMode.firefox" if it shows "false" double click to change to "true", enter your credentials one LAST time when it prompts. The repeating issue stopped for me. No idea why this works?? I would like to thank Yew Kay Yan for this process! It was driving me crazy having to enter Google Credentials Over and Over and Over...
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.