X
Tap here to go to the mobile version of the site.

Support Forum

How can I remove the "Did you mean to go to..." drop down bar when searching for something in the search bar?

B M
Posted

How can I remove the drop down bar that asks me if I "meant to go to" some specific place every time I do a single-word search in the search bar? Apparently this was a problem a few years ago with a Firefox update, and it has just started happening to me after this most recent update. It is extremely annoying and there isn't anything in Options that allows a user to turn it off.

I tried a potential fix posted in one of the older support threads regarding this issue (switching browser.fixup.dns_first_for_single_words preference from false to true) but it doesn't seem to have worked, even after disabling the DNS's "Web Address Error Redirect Service", then resetting Firefox and my router after changing that setting.

Another method I tried was changing my DNS settings I also tried setting keyword.enabled to false, but that did not work either.

I've attached a screenshot of the specific drop down bar I'm referring to.

How can I remove the drop down bar that asks me if I "meant to go to" some specific place every time I do a single-word search in the search bar? Apparently this was a problem a few years ago with a Firefox update, and it has just started happening to me after this most recent update. It is extremely annoying and there isn't anything in Options that allows a user to turn it off. I tried a potential fix posted in one of the older support threads regarding this issue (switching browser.fixup.dns_first_for_single_words preference from false to true) but it doesn't seem to have worked, even after disabling the DNS's "Web Address Error Redirect Service", then resetting Firefox and my router after changing that setting. Another method I tried was changing my DNS settings I also tried setting keyword.enabled to false, but that did not work either. I've attached a screenshot of the specific drop down bar I'm referring to.
Attached screenshots
Quote
Dinushi Dhananjani
  • Top 25 Contributor
4 solutions 193 answers

The only way I've found to rectify this is turning off the "web service" option in the options and changing your DNS to [a better DNS provider].

https://bugzilla.mozilla.org/show_bug.cgi?id=1088050

It's seam like we can able to disable it using this code, you an add this line notification[value="keyword-uri-fixup"] { display: none !important; }

The only way I've found to rectify this is turning off the "web service" option in the options and changing your DNS to [a better DNS provider]. [http://example.com https://bugzilla.mozilla.org/show_bug.cgi?id=1088050] It's seam like we can able to disable it using this code, you an add this line notification[value="keyword-uri-fixup"] { display: none !important; }
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

I saw your question on Reddit first; I'll repeat here:

I think that bar appears if you enter something that looks valid as a host name (like "intranet") and Firefox sends it to search but does a DNS lookup in the background. This was a compromise when the behavior changed from DNS first to search first for one-word queries.

Is ste a bookmark keyword??

Since ste doesn't sound like a valid host name, this could indicate that your DNS service provider (or an add-on) shows a search results page for servers it can't find, and that is fooling Firefox into showing the bar. Very annoying.

I saw your question on Reddit first; I'll repeat here: I think that bar appears if you enter something that looks valid as a host name (like "intranet") and Firefox sends it to search but does a DNS lookup in the background. This was a compromise when the behavior changed from DNS first to search first for one-word queries. Is '''ste''' a bookmark keyword?? Since ste doesn't sound like a valid host name, this could indicate that your DNS service provider (or an add-on) shows a search results page for servers it can't find, and that is fooling Firefox into showing the bar. Very annoying.
Was this helpful to you?
Quote

Question owner

Hi Dinushi, thanks for the quick response. In which section of Options (General, Home, Search, Privacy & Security) would I find the "web service" option so that I can turn that off? I'm not seeing it anywhere.

As far as using that code that you posted, I am new to this. Where would I be inserting that code.

Thanks

Hi Dinushi, thanks for the quick response. In which section of Options (General, Home, Search, Privacy & Security) would I find the "web service" option so that I can turn that off? I'm not seeing it anywhere. As far as using that code that you posted, I am new to this. Where would I be inserting that code. Thanks
Was this helpful to you?
Quote

Question owner

jscher2000 said

I saw your question on Reddit first; I'll repeat here: I think that bar appears if you enter something that looks valid as a host name (like "intranet") and Firefox sends it to search but does a DNS lookup in the background. This was a compromise when the behavior changed from DNS first to search first for one-word queries. Is ste a bookmark keyword?? Since ste doesn't sound like a valid host name, this could indicate that your DNS service provider (or an add-on) shows a search results page for servers it can't find, and that is fooling Firefox into showing the bar. Very annoying.

Hi jscher2000,

I responded to your reply/questions on the Reddit thread, but feel free to reply wherever you prefer.

''jscher2000 [[#answer-1262809|said]]'' <blockquote> I saw your question on Reddit first; I'll repeat here: I think that bar appears if you enter something that looks valid as a host name (like "intranet") and Firefox sends it to search but does a DNS lookup in the background. This was a compromise when the behavior changed from DNS first to search first for one-word queries. Is '''ste''' a bookmark keyword?? Since ste doesn't sound like a valid host name, this could indicate that your DNS service provider (or an add-on) shows a search results page for servers it can't find, and that is fooling Firefox into showing the bar. Very annoying. </blockquote> Hi jscher2000, I responded to your reply/questions on the Reddit thread, but feel free to reply wherever you prefer.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Could you try testsite and then when the bar comes up, go to what Firefox is being told by the DNS server is the page for testsite and see what you find? One possibility is an ISP or extension-driven links page that captures and monetizes typos. These sometimes have a link at the upper right or bottom or opt out, or "why do I see this" or "about this page" which leads to an opt-out page, or more information about the culprit.

Could you try ''testsite'' and then when the bar comes up, go to what Firefox is being told by the DNS server is the page for ''testsite'' and see what you find? One possibility is an ISP or extension-driven links page that captures and monetizes typos. These sometimes have a link at the upper right or bottom or opt out, or "why do I see this" or "about this page" which leads to an opt-out page, or more information about the culprit.
Was this helpful to you?
Quote

Question owner

jscher2000 said

Could you try testsite and then when the bar comes up, go to what Firefox is being told by the DNS server is the page for testsite and see what you find? One possibility is an ISP or extension-driven links page that captures and monetizes typos. These sometimes have a link at the upper right or bottom or opt out, or "why do I see this" or "about this page" which leads to an opt-out page, or more information about the culprit.

Hi jscher2000,

When I do that it brings me to the following: http://www.dnsrsearch.com/search/?q=http://testsite/

On another thread regarding this issue someone said something similar about opting out, which I did before, but it seems that it's not working because it resets my decision to disable the option.

This is the setting that is enabled: "Web Address Error Redirect Service: This preference allows you to opt in or out of TWC's non-existing domain landing service, Time Warner Cable."s

I disabled it (I just now did it again), but last time it just reset itself to "Enabled" and continued to bring bring up the drop-down pop-up. I'm no lawyer, but if Time Warner/Spectrum is resetting that option every time I disable it, that seems, well... illegal. So I have no idea what to think right now.

''jscher2000 [[#answer-1262846|said]]'' <blockquote> Could you try ''testsite'' and then when the bar comes up, go to what Firefox is being told by the DNS server is the page for ''testsite'' and see what you find? One possibility is an ISP or extension-driven links page that captures and monetizes typos. These sometimes have a link at the upper right or bottom or opt out, or "why do I see this" or "about this page" which leads to an opt-out page, or more information about the culprit. </blockquote> Hi jscher2000, When I do that it brings me to the following: http://www.dnsrsearch.com/search/?q=http://testsite/ On another thread regarding this issue someone said something similar about opting out, which I did before, but it seems that it's not working because it resets my decision to disable the option. This is the setting that is enabled: "Web Address Error Redirect Service: This preference allows you to opt in or out of TWC's non-existing domain landing service, Time Warner Cable."s I disabled it (I just now did it again), but last time it just reset itself to "Enabled" and continued to bring bring up the drop-down pop-up. I'm no lawyer, but if Time Warner/Spectrum is resetting that option every time I disable it, that seems, well... illegal. So I have no idea what to think right now.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

On the plus side, we now know exactly why this is happening. On the minus side, like a zombie, it keeps reviving.

If this is a setting in your account, does it work any better to "opt out" using http://www.dnsrsearch.com/prefs/ in Internet Explorer or Edge?

If you need to opt out in each browser individually, that's annoying.

One option would be not to send DNS queries to TWC. This can be an external setting in your router, or a systemwide setting in Windows, or potentially it could be a browser setting, although I don't know the best way to do that these days.

If you do not use rely on the Windows hosts file to override real websites with alternate addresses, and your browsing is not subject to parental controls, you could try DNS over HTTPS. This article has more info: Firefox DNS-over-HTTPS.

On the plus side, we now know exactly why this is happening. On the minus side, like a zombie, it keeps reviving. If this is a setting in your account, does it work any better to "opt out" using http://www.dnsrsearch.com/prefs/ in Internet Explorer or Edge? If you need to opt out in each browser individually, that's annoying. One option would be not to send DNS queries to TWC. This can be an external setting in your router, or a systemwide setting in Windows, or potentially it could be a browser setting, although I don't know the best way to do that these days. If you do not use rely on the Windows '''hosts''' file to override real websites with alternate addresses, and your browsing is not subject to parental controls, you could try DNS over HTTPS. This article has more info: [[Firefox DNS-over-HTTPS]].
Was this helpful to you?
Quote
Senali Madawala
  • Top 25 Contributor
2 solutions 156 answers

Helpful Reply

It seems we will be able disable this new feature via about:config in Firefox 36: https://bugzilla.mozilla.org/show_bug.cgi?id=1088050

For now you can add this line:

   notification[value="keyword-uri-fixup"] { display: none !important; }

to the userChrome.css inside the chrome subfolder of your Firefox profile folder. If userChrome.css doesn't exist there, create it: http://kb.mozillazine.org/UserChrome-example.css

Or, alternatively, you can use the Stylish add-on and create a new user style like this:

   @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
   notification[value="keyword-uri-fixup"] { display: none !important; }
It seems we will be able disable this new feature via about:config in Firefox 36: https://bugzilla.mozilla.org/show_bug.cgi?id=1088050 For now you can add this line: notification[value="keyword-uri-fixup"] { display: none !important; } to the userChrome.css inside the chrome subfolder of your Firefox profile folder. If userChrome.css doesn't exist there, create it: http://kb.mozillazine.org/UserChrome-example.css Or, alternatively, you can use the Stylish add-on and create a new user style like this: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); notification[value="keyword-uri-fixup"] { display: none !important; }
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.