Search Support

Firefox 68.2esr how to confgiure before deploymnet the disabling (not showing) both the library icon "|||\ " and "show sidebars" icons

  • 4 replies
  • 1 has this problem
  • 111 views
  • Last reply by jpietras

more options

using the most recent firefox-68.2.0esr.tar.bz2 I have to configure it for corporate use. I'm using policies.json and userChrome.css files properly installed. They work. But I cannot find out how to disable (i.e. prevent from ever showing) the library icon and the "show sidebars" icons. This has to happen before deployment - users are not allowed to change any configuration/preferences/customization once deployed.

In the image below see the 2 icons at near the top of this snippet of a browser page. Left icon looks like a stack of books (the library icon) and the one next to it on the right is the "show sidebars" icon.

Thanks for your help.

Attached screenshots

Chosen solution

In your userChrome.css file, you want to add the following:

#library-button, #sidebar-button {
     display: none !important;
}

Hope this helps.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

In your userChrome.css file, you want to add the following:

#library-button, #sidebar-button {
     display: none !important;
}

Hope this helps.

more options

Thanks! worked perfectly and solved my issue. Wesley for future issues, and for readers with similar issues, do you have a link to a page that displays the names of all of these objects, like "#library-button"?

more options

When using the userChrome.css, you can explore every element of the browser UI using the Browser Toolbox. Then you can select the elements in your CSS using CSS selectors.

Hope this helps.

more options

Great help, thank you!