X
Tap here to go to the mobile version of the site.

Support Forum

How come tabs won't load until I click on them??

Posted

If I'm in a tab, and click on something, I have it set up to open in a new tab. But lately, I've been clicking on something, going back to the first tab to continue searching or whatever, then, I look up to see the blue horizontal line bouncing from left to right on that tab I recently opened. I go, "Man, that website must be slow!" and click on the tab. Lo and behold, the tab was pretty much frozen until I clicked on it. It was like it wasn't going to load until I clicked on it. Is there any way I can make this not happen? And have tabs load whether or not I'm in the tab I want to load? It seems sometimes that my computer is just slow, and the tab takes a while to load and happens to load when I click on the tab. Either way, it hasn't happened before, and I don't particularly want it to happen anymore lol.

If I'm in a tab, and click on something, I have it set up to open in a new tab. But lately, I've been clicking on something, going back to the first tab to continue searching or whatever, then, I look up to see the blue horizontal line bouncing from left to right on that tab I recently opened. I go, "Man, that website must be slow!" and click on the tab. Lo and behold, the tab was pretty much frozen until I clicked on it. It was like it wasn't going to load until I clicked on it. Is there any way I can make this not happen? And have tabs load whether or not I'm in the tab I want to load? It seems sometimes that my computer is just slow, and the tab takes a while to load and happens to load when I click on the tab. Either way, it hasn't happened before, and I don't particularly want it to happen anymore lol.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17538 solutions 158577 answers

Helpful Reply

Firefox will detect if your computer’s memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while. The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature. Keep in mind that this makes you vulnerable to low memory issues.

  • browser.tabs.unloadOnLowMemory = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Firefox will detect if your computer’s memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while. The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature. Keep in mind that this makes you vulnerable to low memory issues. *browser.tabs.unloadOnLowMemory = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox <hr> *http://www.ghacks.net/2019/03/01/firefox-67-automatically-unload-unused-tabs-to-improve-memory/ *https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/
Was this helpful to you? 2
Quote

Question owner

Memory like HDD, or RAM? I doubt I have less than 400MB on my hard drive, but I also doubt that I would have less than 400MB of RSM because I installed an 8 gig RAM chip. But I will look into it, thanks!!

Memory like HDD, or RAM? I doubt I have less than 400MB on my hard drive, but I also doubt that I would have less than 400MB of RSM because I installed an 8 gig RAM chip. But I will look into it, thanks!!
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Hi Frankie Pro,

Sorry to hear the tabs are not loading as fast as they should.

Have you had any previous issues with any other browsers giving you grief with tabs?

I noticed some extensions that could be causing the slowdown with tabs.

One thing you could try is start in Safe Mode which would disable any active add-ons you may have running or rather potentially interfering with your tabs.

To further troubleshoot browser speed issues : Quick fixes if your Firefox slows down

Let me know if this helps

Hi Frankie Pro, Sorry to hear the tabs are not loading as fast as they should. Have you had any previous issues with any other browsers giving you grief with tabs? I noticed some extensions that could be causing the slowdown with tabs. One thing you could try is start in [[Troubleshoot Firefox issues using Safe Mode|Safe Mode]] which would disable any active add-ons you may have running or rather potentially interfering with your tabs. To further troubleshoot browser speed issues : [[Quick fixes if your Firefox slows down]] Let me know if this helps
Was this helpful to you? 1
Quote

Question owner

I pretty much only use Firefox, but I’ll try the safe mode and also look through my add-ons. Thanks for the tips! I’ll let you know if anything changes.

I pretty much only use Firefox, but I’ll try the safe mode and also look through my add-ons. Thanks for the tips! I’ll let you know if anything changes.
Was this helpful to you?
Quote

Question owner

Alright so, cor-el. I checked and I have 101GB free on my HDD so...what do low memory issues entail?

Alright so, cor-el. I checked and I have 101GB free on my HDD so...what do low memory issues entail?
Was this helpful to you?
Quote

Question owner

To VMagicModel: So I looked at my add-ons, and there were 2 that have been disabled (Amazon Assistant for Firefox, and Mozilla Partner Defaults.) They both say that the add-ons, “could not be verified for use in Firefox and has been disabled.” So I guess I should just remove those extensions completely?

To VMagicModel: So I looked at my add-ons, and there were 2 that have been disabled (Amazon Assistant for Firefox, and Mozilla Partner Defaults.) They both say that the add-ons, “could not be verified for use in Firefox and has been disabled.” So I guess I should just remove those extensions completely?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17538 solutions 158577 answers

This is about free RAM and not about your hard drive. If you open a link in Firefox either in the background or with focus set to this tab then Firefox should always load this tab. If this is about restoring tabs from the previous session then there are pref that control if you restore on demand or that all tabs are opened automatically.

Otherwise you might have an extension that comes with this feature.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
This is about free RAM and not about your hard drive. If you open a link in Firefox either in the background or with focus set to this tab then Firefox should always load this tab. If this is about restoring tabs from the previous session then there are pref that control if you restore on demand or that all tabs are opened automatically. Otherwise you might have an extension that comes with this feature. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote

Question owner

Hm. Ok. Well I don’t know how to start in safe mode, but I don’t have any extensions besides AdBlock. I got rid of Amazon and some kind of Mozilla Defaults thing because it said they had been disabled due to them not being verified.

Hm. Ok. Well I don’t know how to start in safe mode, but I don’t have any extensions besides AdBlock. I got rid of Amazon and some kind of Mozilla Defaults thing because it said they had been disabled due to them not being verified.
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Helpful Reply

Hi Frankie Pro,

Use your best judgement! Especially if you do not recall downloading those extensions from the Firefox Add-ons website.

To start in Safe Mode

  1. Click the '3 bar' menu icon on the top right corner of the web browser
  2. Click Help(?) towards the bottom
  3. Click Restart with Add-ons Disabled...
  4. Click Restart again, when prompted choose Start in Safe Mode
Hi Frankie Pro, Use your best judgement! Especially if you do not recall downloading those extensions from the [https://addons.mozilla.org/en-US/firefox/guides/organize-tabs-and-bookmarks/ Firefox Add-ons] website. To start in Safe Mode # Click the '3 bar' '''menu''' icon on the top right corner of the web browser # Click '''Help(?)''' towards the bottom # Click '''Restart with Add-ons Disabled...''' # Click '''Restart''' again, when prompted choose '''Start in Safe Mode '''
Was this helpful to you? 2
Quote

Question owner

VMagicModel Ok yeah. Alright cool. And do I pretty much do the same thing to restart and get out of Safe Mode?

VMagicModel Ok yeah. Alright cool. And do I pretty much do the same thing to restart and get out of Safe Mode?
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

To get out of Safe Mode you could just exit the browser and it will relaunch normally.

To get out of Safe Mode you could just exit the browser and it will relaunch normally.
Was this helpful to you? 2
Quote

Question owner

Alright sweet. I’m gonna try that now.

Alright sweet. I’m gonna try that now.
Was this helpful to you?
Quote

Question owner

Alright well, it seems my PC may just be running a lot slower than normal because even in Safe Mode the tab won’t load completely until I click on it. So I don’t know, I might try cor-el’s idea, what do you think?

Alright well, it seems my PC may just be running a lot slower than normal because even in Safe Mode the tab won’t load completely until I click on it. So I don’t know, I might try cor-el’s idea, what do you think?
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Hi Frankie,

Definitely follow up on his suggestions!

You also try creating a New Profile.

To do this :

  1. Type about:profiles in the address bar in your browser
  2. Under About Profiles click the Create a New Profile button
  3. A Profile Wizard will launch, click Next
  4. Create a new profile name if you wish or just click Finish
  5. Go to the newly created Profile and click Launch profile in new browser
  • See if the issue went away
Hi Frankie, Definitely follow up on his suggestions! You also try creating a New Profile. To do this : # Type '''about:profiles''' in the address bar in your browser # Under About Profiles click the '''Create a New Profile '''button # A Profile Wizard will launch, click '''Next''' # Create a new profile name if you wish or just click '''Finish''' # Go to the newly created Profile and click '''Launch profile in new browser''' * See if the issue went away
Was this helpful to you? 1
Quote

Question owner

Hey cor-el, so that UnloadOnLowMemory configuration was already set to false. I think I’m coming to the conclusion that my computer is running really slow lately.

Hey cor-el, so that UnloadOnLowMemory configuration was already set to false. I think I’m coming to the conclusion that my computer is running really slow lately.
Was this helpful to you?
Quote

Question owner

Issue is not going away. I don’t know what’s going on. I’m sorry for all the trouble. Thanks for all your help VMagicModel.

Issue is not going away. I don’t know what’s going on. I’m sorry for all the trouble. Thanks for all your help VMagicModel.
Was this helpful to you?
Quote

Question owner

Hey cor-el. I can’t seem to fix the issue. I appreciate your help in trying to resolve the issue.

Hey cor-el. I can’t seem to fix the issue. I appreciate your help in trying to resolve the issue.
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Hi Frankie,

No worries! I hope we can resolve this issue. Are other websites loading fine? You could try reconnecting your connection with your ISP if possible.

Make sure your Operating System is up-to-date and your video card.

Also do a free virus scan with Windows Defender.

See the article below to try and speed things up!

Reference article : Quick fixes if your Firefox slows down

Hi Frankie, No worries! I hope we can resolve this issue. Are other websites loading fine? You could try reconnecting your connection with your ISP if possible. Make sure your Operating System is up-to-date and your video card. Also do a free virus scan with Windows Defender. See the article below to try and speed things up! Reference article : [https://support.mozilla.org/en-US/kb/quick-fixes-if-your-firefox-slows-down Quick fixes if your Firefox slows down]
Was this helpful to you? 2
Quote

Question owner

Thank you. No it seems my computer is just slow all around. I’m looking in Task Manager, and it says 100% of my CPU is being used. I looked in the “Processes” tab and “AcerCloud Client (32 bit) is taking up like 70% of my CPU! I clicked “End task” and it’s been at a steady 0% since. I just put my computer on sleep and I will wake it up in about 5 minutes and see if the AcerCloud Client is back up to 70%. If it is, I’m just gonna get rid of it.

This would heavily increase my PC’s overall speed and may help with the Firefox issue. I will certainly let you know if it does.

Thank you. No it seems my computer is just slow all around. I’m looking in Task Manager, and it says 100% of my CPU is being used. I looked in the “Processes” tab and “AcerCloud Client (32 bit) is taking up like 70% of my CPU! I clicked “End task” and it’s been at a steady 0% since. I just put my computer on sleep and I will wake it up in about 5 minutes and see if the AcerCloud Client is back up to 70%. If it is, I’m just gonna get rid of it. This would heavily increase my PC’s overall speed and may help with the Firefox issue. I will certainly let you know if it does.
Was this helpful to you?
Quote
WMagicModel
  • Top 25 Contributor
  • Administrator
14 solutions 204 answers

Seems like you nailed it. Good work! :)

Seems like you nailed it. Good work! :)
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.